Music is being shuffled even when I click "Play" [Solved: Shuffle Mode on Queue ]

In Album view (show all) I cannot get rid of the two only options: radio and shuffle. Even when I select an album, playing (play button) it defaults to shuffle.
Even unticking shuffle in the albums play options doesn’t work. Neither did a restart.
Please advise.

In album view all albums are displayed, having the option to shuffle all or start radio seems sensible, if you select one album then you should see the play now, add to q etc.

Right, that’s what I also thought. Unfortunately shuffle continues in Album view even when I “play album” as I mentioned before.

Do you have shuffle set? When you click on a track that is playing do you see the shuffle symbol on eg blue? The two shuffle settings are independent.

Can you post a screenshot of the screen or view you’re looking to change?

I’d check here for to see how your “Play Actions” are set-up.
Unless this is what you meant by “unticking shuffle in the albums play options”??

Thanks all for responding.

Play actions for albums are set like here:

With an album, the settings reflect these play preferences:

But when I press “play now” in the single album view, Roon does not play the tracks in their original order (1, 2, 3…), but in a shuffled sequence (7, 2, 9, 3…).

Thanks for the continued feedback @WKW, very appreciated!

Continuing forward, I would like to see what the “queue” looks like after you have hit “play now” on a mentioned album.



There may be some interactions that I do not quite understand.

I must say that before trying to play Black Lotos I had a playlist set to shuffle the other day. Somehow I didn’t manage to remove the shuffle command as ‘shuffle’ also did not show up as a button when I had the single album view Black Lotos.

I could overcome this problem by going back to the playlist used the other day, selecting one of the playlist albums and untick the ‘shuffle’ button. Only then ‘Black Lotos’ played as requested.

If you’re playing content that has a defined order (like an album or playlist) there are two ways you can shuffle:

  • Click the Shuffle Play button - Once you have this button enabled, the content you select will be added to the queue in a random order and played immediately

  • Enable Shuffle Mode on the Queue - if you enable this mode (by clicking the Shuffle icon shown in Eric’s screenshot above), anything that’s queued up will be shuffled, and any other content you play or add to queue will be shuffled.

So, based on this:

It sounds like you have the queue set to Shuffle mode, which means anything you play will be shuffled. You can confirm this by looking for the Shuffle icon in the footer:

Right. That was it. The player was still i shuffle mode even though I had selected only one album.

Thanks to the helpful community.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.