Music jumps from time to time, ridiculous?

It’s getting ridiculous at home.

I’m trying to get rid of Music that jumps, skips beats etc.

At first i simply used Kodi in the living room on various hardware and the problem never occured. With going forward directing to multiroom my first approach was Sonos.
In the living room i tried a Sonos Connect but besides the skipping music it simply wasn’t good.

So i searched a lot for an excellent product for Multiroom and finally found Roon (the Software is really great and the way it handles my music is just astonishing.)

I installed it and was very happy, on PC, on the Sonos Play 1 in Kitchen, on the Mac in another room and on the Yamaha RX-A 3040 with Airplay everything was just fine, but then I decided to go a step further and bought an Allo Digi One Player and a linear PSU and suddenly my problems were back. On some tracks it just jumps and skips beats like there was a technical problem.

I had several approaches to find the culprit

  • I tried to fix things in the network, like new connections and fixed a cable which wasn’t good anymore

  • i bought a few new Network-Cables

  • I tried to have a look at the log-files

  • I suspected the fritzbox had a part in this and put another router in between.

  • I tried to push buffer to 500ms.

  • I even tried a filter for AC.

  • I took my Server out of another room put it in the living room next to the ALLO to avoid network path through multiple switches.

  • i switched signal ways, DSP on or off

  • i converted the files with platinum Notes back and forward. It does not occur on every file! At the Time i had Sonos installed, i even streamed the music directly from amazon music.

  • Today I built a housing with some aluminium foil for maybe theres something disturbing the hardware, but it still jumps.

Needless to say, the same music files work just fine on other players…

Is there anybody out there knowing this problem with something to point me at?

(test @support )
Setup is:

  • Roon Core on Unraid using asrock c2550d4i strictly WD Red HDDs

  • Player is Allo Digi One Player

  • PSU is AUDIOPHONICS Linear Regulated Low Noise Power

  • Amplifier is Yamaha RX A3040

  • Network is Fritzbox 7490, 2 Switches Gigabit Ethernet 1 being HP and 1 being TP-Link

  • Connection to Yamaha via 0.5m digital Coax cable (tried others)

Hi are any of your devices connected via WiFi, if so I’d focus on replacing with hardwired eithernet.

Everything which is needed is connected via Gigabit Ethernet. Wifi is just for mobile Devices like 3 Smartphones and Firetablet.
Especially Server and Clients are hardwired.
Only thing not hardwired, is Sonos Play 1, which works fine.
i also tried WiFi for the Allo, which was the same and i picked my older Raspberry Pi with Hifiberry DAC+ and another time with Hifiberry Digi+

Are you playing on all of your zones simultaneously? Try Sonos exclusively. Also, start an offending track, then click the little star next to its name in the ribbon at the bottom of your control, take a pic of the Signal Path, and post it here. Finally, is DSP on or off?

Please. :slight_smile:

Tested Single Zone only had DSP switched on, and switched it off again, like this.

hm, the thread was moved to software, but i think that’s wrong. it happened with sonos before roon.

Hi @Kai_Schmalenbach ----- Thank you for for the report and sharing these observations you have made with us. The feedback is always appreciated!

I have read through your posts and at first glance it feels like you are experiencing audio dropouts and these are almost always caused by some sort of a performance issue. So our goal moving forward should be to try and isolate as many variables as possible to see if we can pinpoint the "culprit. However, before we do that, there are some minor details from this thread I would like to ask you about. Please see below.

  1. In your posts, you mention the following:

    “…bought an Allo Digi One Player and a linear PSU and suddenly my problems were back.”

    “it happened with sonos before roon.”

    • My assumption, based on the above, is that you experienced this behavior outside of Roon, is this correct? If this is indeed the case, was this before the Allo Digi One Player was introduced into your setup?
  • The current Roon core has an SSD installed for your Roon database as mentioned in our minimum requirements, yes?

  • Please verify for me where your musical collection is being stored/accessed from.

  • I am assuming that the experience is the same with both locally stored and TIDAL content during playback, please confirm.

  • Do you notice any patterns in behavior when you notice that the music begins to “jump”? For example, does this happen on every type of file format?


1 Like

Hello Eric,
thanks for your quick reply! Appreciate that!

Yes i experienced it before. In fact this experience with Sonos was the most important reason for searching another solution.
It was happening with Sonos on the Sonos connect, connected to my amp, reading the files from the same unraid based storage.
It disappeared with roon, as i was using roon on unraid sending directly to the Yamaha RX A 3040 via Airplay.

No. I will try that, but my hopes are not getting very high on that point, because it is the Allo Digi One only who has this problem, all other players (PC, Mac, Yamaha(Airplay), Sonos Play 1) are working fine. The Problem appears only when trying to connect a player to my amp. (Maybe i will do a test with the sonos connect again.)

It’s accessed from the very same Unraid System based on an asrock c2550d4i. i also tried multiroom without any issues, the CPU goes to max. 20% when playing 3 Zones with different material. Even if all transports are using different material and using DSP-Filters. So i never even thought of performance issues.

Don’t know because i don’t have aa tidal account yet. But i had the same problems, with the very same audio-files using Sonos and amazon music.

It’s not based on format, but i have Files that have that behaviour and other files that don’t. One Album, which is the one you can hear it best was tested in different formats. It works on every other player but has problems on the allo

It’s late now, but tomorrow i will do a test for performance with a DSD256 file on different players, because as i said till now i never even had performance issues on my mind.

One question though, i will only need to move the core to a ssd?

Kind regards

Yes, that’s correct… having the Roon database on SSD really improves the performance of the application.

1 Like


Based on your information I believe that the RPi/Allo endpoint and its data connection/processing is most likely causing the issue. I don’t know about the pre-Roon Sonus setup, this might have suffered from the same issue, or might be unrelated.

What RPi are you using? I’ve had the same stuttering audio issue from time to time with a RPi 2 and the Allo DigiOne. This was a lot less when I switched to a RPi 3 and fully disapeared when I removed the USB SSD that I had connected to the RPi.

Another cause could be the ethernet connection (could also explain the previous issue with Sonos). Or a combination: somewhat degraded ethernet connection in conjunction with the less than optimal USB/Ethernet bus sharing of the RPi.
Can you tell a bit more about the connection between the server and the endpoint (switches, cable length, etc)

1 Like

Hello Eric,
a short update. I thought i had another SSD lying around, but that’s not the case i used it elsewhere, so i ordered another one. Will report back after finishing the task.

1 Like

Hello Albert,

thanks for your reply.
The Pi is a Pi3, so it’s not about the performance of the device, i think.

The LAN is exactly what i was thinking, but i’m stuck there, i bought new cables and new connections at a place where my rabbits killed a cable :slight_smile:
the unraid is in another room than the RPi between the places there are aroung 10 Meters of Cat6 Network cables and two switches one being a HP one being a TP-Link.
Both switches were changed when analyzing the problems. All Switches and the connection on the unraid are gigabit.
I pulled my NAS and brought it in the living room there were only 2 Meters and a switch between NAS and RPi, while the problem remained.

Hello Carl,

thanks for your reply.
I never even thought about that, because the performance already is incredible in Comparison to things like Sonos or Volumio. :slight_smile:

1 Like

for my test i might need to move the core to other hardware.
Will that give me any problems?
Will it be enough to shut down one Core and start another?

Hi @Kai_Schmalenbach ---- Thank you for touching base with me! Here is wha I would recommend for the proposed test.

  1. Before anything, please make a backup of your current Roon DB.

  2. I would then stop Roon (or Roon Server if applicable) from running on the current core machine.

  3. Next, pick the device you’d like to setup as the new core and setup Roon.

  4. Please let me know what the experience is like when your DB is being hosted on an SSD.


1 Like

It seems like you have been doing all the right things with regard to testing the network/ethernet connection. I’m afraid I have run out of ideas here. My DigiOne has been running smoothly ever since I started using an RPi 3 and removed the attached SSD storage.

Maybe one more suggestion:
Would you happen to use any VLan or managed switch functionality on your network? This sometimes generates a lot of frames being transmitted that bounce (because of the fact that they are tagged for a different VLan) and cause a lot of re-transmittal. Since the RPi uses a shared bus for USB and Ethernet it doesn’t work very efficient and sometimes gets clogged by this.
Just a thought…

Hello Albert,
thanks for your reply. No there are no VLANs in my Network, this would be a bit over the top for my Home-network :slight_smile:
Still, i’m not done with being suspicious about network as a reason for the problems

Hello Eric,

i switched to SSD already, but the problems remain as is expected. i can’t see this much of better performance now either.
Regarding the performance thing i did a bit of a test with a DSD256 file which is sent through DSP and over WLAN to the farest Location away from the Accesspoint to a macbook and it worked without showing any kind of performance issues BEFORE i added the SSD. So i’m pretty sure it is not about performance… because everywhere else it works fine just not on my main Set for Music listening :frowning:

I’,m really lost with this problem, as i never was before.

I can’t figure out, what a Sonos Connect and a RPI 3 have in common, which may be a good lead to finding the problem. if i was sure it’s the hardware which is kind of, i don’t know, susceptible for something in my Network which they don’t have in common with the bluenode 2, i would immediately go for that, but i don’t want to kill another 500€ :slight_smile:


Two more test I would propose:

  • remove the DigiOne from the RPi and use the analog output of the RPi to feed into your amp (this takes the DigiOne out of the equation)
  • connect your Mac to the ethernet cable instead of the RPi and switch off WiFi (to test the network connection with the same Roon load)

Under normal circumstances a 1Gb ethernet connection using CAT-6 cable should have plenty of headroom to provide a stable data stream for over a dozen audio streams. Even with Roon which is rather chatty on the network. Are you sure that the network is operating at 1Gb (can be verified by the LED color at the UTP connectors on most switches)? Still, even 100Mb should give plenty of headroom.

I’m curious to know what the two tests result in!

Hi @Kai_Schmalenbach ----- Thank you for the update and sharing the observations made after performing the proposed test. The continued insight and feedback are both very appreciated!

Continuing forward, I agree with the suggestions made in @Albert_Jochems post above, thank you Albert :+1: Additionally I wanted to also inquire about the switches you mentioned in your initial post (i.e “Switches Gigabit Ethernet 1 being HP and 1 being TP-Link”). Can you please verify the exact model of these devices for me?