Music library Disappeared After 2.0 1223 Production Update [Hotfix Build 1234 Released]

Sure they are different causes and fixes. But people were happy to report the ARC issue as fixed after the update, but apparently nobody did for the storage issue. Assuming that both affected populations are similar kinds of people (which seems likely), one would statistically expect success reports for the storage issue as well. If they aren’t coming, it’s possibly hinting that the storage issue wasn’t fixed for many/anybody

Same here. Hot Fix did not fix.

John C.

I don’t understand why it is not possible to let those of us having this issue “downgrade” to a previous build. I have backups from previous versions I can use to restore my database, but even if I didn’t, I’d rather have the previous working version than the current 1223 non-working build. Surely Roon keeps prior software versions; put the previous build on a server somewhere, and send those of us having issues a link. We can delete the 1223 version, install the “old” one, and at least have a functioning installation until the local library issue is resolved.

John C.


^^^ What John Said ^^^

I agree with John and Ventoux - either give us the old version so we have our music working or reduce our annual payment.

Sorry everyone, we have not been able to reproduce this issue in-house, but based on the logs collected from the original reports we saw an obvious bug which could have led to the behavior being observed here.

We’re in the process of collecting more information and are working to isolate the root cause and issue a fix.

Thank you Andrew! Let us hope it works this time!

Quick update… the devs had it right, but due to an error in the build process the complete fix wasn’t included in yesterday’s build. We’re generating new builds now and will push them out ASAP.

1 Like

I see that I guessed correctly!

Let’s not forget the folks on the “Early Access” tree this time…please!

OK. Build 1234 is out. Please give that one a try.

Lookin good! :pray: :pray: :pray:

Thanks for staying diligent!

It is working for me.
Thank you

What about the folks in the “Early Access” tree?? Are we stuck on 1228 forever??

So far so good :grinning:

Since I deleted all my playlists (that were previously showing - “unavailable”) I went ahead and restored my database from a previous backup before the Feb 28 update - after seeing Roon was behaving as it should.
Playlists are all back -
But - Roon is taking forever (seems stuck) at retrieving metadata for albums I’ve added over the past 2 weeks. Importer shows message “Metadata improver is paused” - problem verifying connection to Roon servers??? Albums show - but no album art or metadata.

Anyway - I’ll let it run overnight before I attempt to restart my Nucleus Core.

Thanks for the update.

A post was split to a new topic: Missing Library Content, EarlyAccess Build 1228

It worked! Thanks so much!

Newest build works for me. Thank you!

John C.

1 Like

Newest build works for me. Thanks so much.
Sam S.

1 Like

Thank you to those of you who volunteered logs and additional information to help the team sort out this issue. We’ll be splitting off threads for users who are continuing to experience symptoms, so we can troubleshoot directly.

By all indications, the fix we have (successfully) merged with the most recent release has resolved the problem with external storage failing to appear. We’ll be monitoring this thread closely regardless.

We truly appreciate your patience as we worked to resolve this case.

1 Like

What happened to build 1232?

I updated yesterday to it and now today it says I need 1234 and there is no discussion of 1232 anywhere (despite me running it)