Music library Disappeared After 2.0 1223 Production Update [Hotfix Build 1234 Released]

Same exact issue here except running Roon on a Mac Studio running OS 13.2.1…

Never had an issue like this with doing an update.

Tried similar steps with removing and re-adding the storage location - no change still missing all albums and tracks in the library.

:mega: Staff Note :mega:


@rcarp2musicmac, I have moved your post to a new #support thread, as this is the preferred method to get assistance.

Whilst you have the same symptoms, the reason may be different, so please complete the following template. Thanks.

Please be sure to include details of your core, network, storage location of your media files, and any messages displayed by Roon. Thank you.

Roon Core Machine

<!‐-Include your operating system and machine info (Model, CPU, RAM)-‐>
<!‐-Write below this line-‐>

Networking Gear & Setup Details

<!‐-Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using VPN-‐>
<!‐-Write below this line-‐>

Connected Audio Devices

<!‐-Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)-‐>
<!‐-Write below this line-‐>

Number of Tracks in Library

<!‐-Tell us how large your music library is, eg. “30,000 tracks”-‐>
<!‐-Write below this line-‐>

Description of Issue

<!-‐Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!-‐>
<!‐-Write below this line-‐>

Including these details in your first post helps resolve your issues faster.

Info on Current Config

Roon Core Machine

Mac OS 13.2.1
Mac Studio M1 Max
64 Gig Ram
External SSD Drive connected via Thunderbolt (where Music storage is located)
Internal SSD (where Roon is installed)
Roon 2.0 Build 1223

Networking Gear & Setup Details

Eero Pro 6E - Router
NETGEAR - 5-Port 10/100/1000 Mbps Gigabit Unmanaged Switch

Connected Audio Devices

Matrix Audio ElementX Streamer connected via Ethernet

Number of Tracks in Library

3,000 Albums
40,000+ Tracks

Description of Issue

Updated Roon 2.0 to Build 1223. On restart, my Music Library was gone - Now showing 0 Artists and 0 Albums and 0 Tracks.

Remediation attempts:

Did a force rescan - no effect
Removed music storage drive and re-added - no effect

Update: Connected Audio Devices - Matrix Element X Streamer connected via Ethernet

From the logs - looks like Roon thinks my external SSD drive is offline… It works fine with other audio players - Apple Music

Log Entry:
03/02 09:18:05 Info: [broker/locations] storage location backend (Folder:Name=:Location=FileBrowser.Entry: Media, AppleAPFSMedia : /Users/robertcarpenter/Music/Hi Res Audio:Id=a2d1ab6e-e420-4d10-896f-3806f4432a56) offline reason changed to: DriveNotReady

Check that Roon has access to the drive.

Go to Privacy & Security, and Full Disk Access.

Set Roon disk to Full Access in Privacy & Security settings.

No Change - still missing Music Library

I am having the same identical problem after upgrading to 2.0.1223

Same thing happened to me.

Nothing has changed except the Roon update.

Log shows the drive with my library on is “Offline” because “Drive Not Ready”

If I DISABLE the storage location (not remove it), exit my Roon Core, restart Roon Core and then go and ENABLE that storage location again, Roon instantly picks up all of the missing files. They’ll play fine too. However, if I exit the Roon Core and restart it again - it loses everything again.

Everything else can access the drive fine, as can Roon (temporarily) if I do the above.

I tried to replicate what you did and I observed the same behavior.

Think I am seeing a similar behaviour here too! followed @Torq in the post above and low and behold the local albums and tracks appear and can be played. Additionally though any individual tracks previously highlighted as favourites still show as unavailable and this odd behaviour seems to also extend to some tidal tracks highlighted as favourites??

Ditto. I’m running win10 and tech support separated this thread from mine (for whatever reason?) but this all is exactly what happens to me after the most recent update.

@jato1569, @Torq, @Evo1668, @jmathers, @rcarp2musicmac, I had a similar issue with an earlier earlyaccess release. Can all of you having this problem see if your songs appear by selecting Tracks view? It was an odd problem, no Albums were visible (in the Albums view category) but all my Tracks were seen and playable. I am wondering of B1223 reverted somehow.

I’ve had that happen from time to time on my Nucleus with Dell client. No albums showing up on one view, but they all show up when I click on another view. That fixes the issue for the first view. It’s not just recent.

In my case it seems to be a different problems. Even selecting tracks view the libray is empty

1 Like

Try switching album view from artist to date added and then back.

Changing views does not fix anything with my issue. Storage library is still showing offline in the logs. Very frustrating that an incremental update could cause such an issue. Roon is dead in the water for me. There better be a hot fix soon.

1 Like

All my albums and tracks appear, both Tidal and local content. But when I view the tracks from a local storage album, you see the album track, but it shows “unavailable” tag against each track and won’t play. If I go to Library under settings clean library. I can check a message saying “ clear several thousand tracks (ie all my local tracks) that can’t be associated as storage location doesn’t exist”

What is the file system type of the problem drive?

On my Mac Studio, the Storage Library is an APFS formatted external SSD Drive. My guess is that something changed in the update with their “online” storage drive detection algorithm. Every view is showing storage offline. No other variables, such as OS updates, changed except for the Roon update. Worked fine prior to the update. Did the 1223 update - now, storage is offline and no music is available to play from the library except for Qobuz favorites which is not dependent on the storage library.

1 Like

Can you add a Qobuz favorite to the library? I can’t do that either.