Music Library / System doesn't work

Core Machine

Nucleus

Network Details

  • Router: Speedport Smart 3 connected through W-LAN to Speed-Home Wifi (Mesh)
  • Then connected through cable to Switch which is then. connected to Nucleus

Audio Devices

  • AppleTV (Wifi)
  • Denon Home 350 (Wifi)
  • Exa Sound e32 dac, sigma included (LAN Network)
  • Denon AVC-X 8500H (Network cable)

Library Size

My music library takes up ca 1GB on a 4GB hard drive.

Description of Issue

Hello, I have a problem with Roon.
I’ve had the software for a year (lifelong license) and everything ran smoothly. But now (since 3 weeks ago) when I open the app on my MacBook, iPad or iPhone I don’t have access to the music stored on the Nucleus, nor to the music on Tidal. In the screenshots you can see that Roon shows that there is currently no music in my library. However, when I go to the data folder through the Finder I can clearly see that my music is still there. My profile is also not shown properly, I don’t know if Roon recognizes it. The Nucleus is connected to all my devices.
I have tried restarting the nucleus.
Now I am at a loss.
If you could please help me.

Can you just check that you are connected to the Core on your Nucleus? In Roon, go to Settings > General, and that page will tell you where your Roon Core is located.

I would:
Log out of the nucleus
reboot the nucleus and any devices it touches, nas, wifi etc.
This just gets a good steady state, hopefully.
Log back in.
Does your profile look correct?
Do you have backups?
Have you try to restore?
3 weeks ago, recall what may have occurred?

If you go into settings → storage. is your storage device mapped properly?
It sounds like the configuration was corrupted somehow and needs to be prodded back into being.

Hi Geoff,

Yes my nucleus is connected as the roon core.

Hi Paul,

I have rebooted my entire system but everything is unchanged.
Regarding my profile, some changes I made (like profile picture etc.) seem to have been lost.
Sadly I have not made any backups, I should have, I know.
Three weeks ago…the only thing I can think of is that apple updated the software on all devices.

My storage device is mapped properly, yes.

Thank you for the answers.
I need clarity for myself, so apologies.
in settings → storage you see something similar?

Clearly your system names and paths, Correct?
And still no albums are present?

If so, please click the 3 vertical dots and force rescan.

This will start rebuilding your database.

I recommend making a backup once that finishes. It can be scheduled to run daily when you’re asleep.

Thank you for your help.
This is what I see, The path should be the same as usual.
No, still no albums present and when I force a rescan the scanning symbol is there for only a second.

Thank you, how can you make backups?

Again thanks. so internal storage. and it is mapped.
Easy part first backups
settings → backups
“backup now” make one first. then play with scheduling them there.

I have no clue part now.
You forced a rescan on both and neither populated albums?
I do not have a nucleus to walk you through the gui.
I’ll take you at your word files have been populated.
Now I will follow along and learn too.

Thank you very much for your help so far.

to answer your last question, yes rescan on both, nothing changed.

Hi Mario, i have exactly the same problem: no tracks (all 0-0-0) and Roon cannot find any audio devices … no Qobuz / no access to NAS …
I had uninstalled and reinstalled ROONServer Software. on top Roon - Deskop MAC is also uninstalled and now everything is new installed. Result = The problem remains.
I will wait and see if it works again tomorrow. Best Olaf

Hello Mario, the problem persisted today. Then I uninstalled ROON on all devices (software, apps, etc.) and reinstalled and set up everything again.
That helped today. Now I can access everything again and listen to music. Best Olaf

2 Likes

Hello @Maitzo,

I’m very sorry to hear about the issues you’re experiencing…and thank you for letting us know and engaging on the community to find a solution.

Could you please share a screenshot of the Web UI?

So we can take a closer look, are you able to access your database and zip up the Logs folder for us?

If you can zip up that folder and send us a copy here, we can get a sense of what’s gone wrong here.

Thanks in advance!

P.S. Thank you @MamaTried and @Geoff_Coupe for your help! :pray:

P.P.S. I’m so glad you’re all set, @Ole_K! Thanks for keeping us posted.

1 Like

You should never make backups to internal Nucleus storage as it is all automatically watched. ROCK NUCs function differently on this.

Good point.

@Maitzo - in the screenshot of the Storage settings for your Nucleus, I see that you have defined \\Nucleus\Data as a Watched Folder. This is wrong, and should be removed. Watched Folders should never be defined as being in the M.2 SSD of the Nucleus. This is only for the Roon OS and Roon software, never for music files.