My Albums very slow to populate

Roon Core Machine

Windows 11, Dell Precision Tower 3431, i9-9900 CPU @3.10 GHz, 32 GB RAM

Networking Gear & Setup Details

CenturyLink Technicolor C2100T modem and Netgear Orbi V2.7.4.24 for Wi/Fi

Connected Audio Devices

Moon 390 with Ethernet

Number of Tracks in Library

38386 Albums, 543425 tracks

Description of Issue

Since the latest update to Roon, it has been extremely slow to load My Albums. They show up at 32 albums at a time. When I scroll down it takes about 35 seconds to load another 32 albums. The albums are blank squares until they get populated.
When I try to edit an album, it takes about 15 seconds to show up, 15 seconds after I click edit, and then about 1 minute 20 seconds to save it after I change the Artist Name.

I didn’t mention but I have the music stored on three different QNAP NASs, all of which are up to date with Firmware. Rebooting my computer does nothing to help. It takes about 30 seconds to start an album now vs a few seconds previously.

Are you NAS servers and your Roon Core attached via Ethernet or WiFi or a mix? What do you mean by:

The NAS are connected to my computer/Roon Core with Ethernet, as they always have been. If I stream from the Roon to my Sonos, its over Wifi with the Orbi

I use the Private Internet Access VPN for most internet traffic for the last several years.

Have you tried to see if cleaning up your library may help (this is under Settings → Library → Library Maintenance)? May I also assume you are using Roon 2/0 B1211 or B1216 (earlyaccess) for your Core and any corresponding Remotes?

Not sure if the VPN may be an issue as Roon does not recommend using one except in certain scenarios to enable Roon ARC when ISP networks are configured with CGNAT.

Have you tried clearing the image cache?

I have done the library maintenance and cleared the cache to no avail. I’m going to try uninstalling and reinstalling now that the backup is done.

I ended up disabling the six folders I had connected to Roon, cleaning up the library by deleting everything, and then enabling the folders and importing all the tracks again. It appears to have helped. It still takes a few seconds to load the albums when I scroll to the bottom but it’s a lot better than before. Not sure why it happened in the first place but that seems to have fixed the issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.