My Experience Installing Roon ARC Under Windows Subsystem for Android

I did some tinkering with this and installing ARC under WSA is pretty simple. It just needs to be installed as a 32bit ARM application and then everything will work just fine, otherwise ARC will crash upon playback. To install ARC download the apk from Roon directly and then grab a copy of adb/platform tools from Google. Enable developer mode in WSA and run the command:

adb install --abi armeabi-v7a RoonARC.apk

ARC works perfectly under WSA with the armeabi-v7a version. I hope this helps someone else!

For a really easy solution download platform-tools and create a batch file in the same directory as adb.exe with the following text:

cd /D "%~dp0"

adb connect

adb install --abi armeabi-v7a %1


taskkill /f /im adb.exe

Then anytime Roon releases an update for ARC, just drag and drop the ARC apk into the batch file.

Please note, the first time adb connects permission will have to be granted.

EDIT: Made a small usability fix to the batch file. I also can confirm that this will work to easily upgrade ARC to the latest version.

EDIT 1: Added a line at the end to kill adb.exe since it will continue to run after install.


Follow these steps when “Amazon Store” is not available in your country
Install Windows Subsystem for Android with Powershell:

1 Like

Thanks Robert for both post’s.
I might well try this on my touchscreen laptop later :+1:

Nice! This worked for me as well. After struggling with really inconsistent luck with Roon over Wireguard this is a nice workaround the meantime. Would really like ARC to run natively on Windows, but this is a start. Thanks!

If your issue with Roon and wireguard has to do with the local endpoint disappearing and you are using Windows have a look at my post here. It may have to do with modern standby. I developed an easy workaround using autohotkey:

That is indeed my problem, but unfortunately none of those suggestions seem to work after the latest core update. Worked pretty flawlessly last week, but not at all this week …sigh…

If it appears and then disappears try killing and restarting raatserver.exe. If that is the solution you can try my autohotkey script which when compiled and run will do it with a keystroke quickly rather then manually doing it each time. Also make sure that you are tunneling all traffic through the wireguard tunnel, not just the lan. Ideally when you are connected and check your WAN IP address you should see your home one.

Interesting… yes it was an issue with tunneling only the lan. As soon as I went back to it popped right back up. Unfortunately that limits my in the office download speed to my home internet upload speed. Guess there’s no way to have it all :sob:

Unfortunately no, you have to tunnel everything. Fortunately I have a gigabit line at home so it’s not a problem for me. :grin: