My Roon Core on a 2012 Mac keeps crashing. It is totally unusable right now

Roon Core Machine

MacOs Catalina v10.15 beta
MacBook Pro (Retina, 13-inch, Early 2013)
2.6ghz i5, 8GB DDR3

Networking Gear & Setup Details

Arris Surfboard router via ethernet cable

Connected Audio Devices

Cambridge DacMagic100
USB Audio cable

Number of Tracks in Library

approx 3000 tracks

Description of Issue

My Roon Core on a 2012 Mac keeps crashing. It is totally unusable right now since the latest update.

@1brianhitch1, a fellow user here, but I have a few qustions that may assist the community and Roon staff in providing improved support for you.

  1. You state that you are running MacOS 10.15 Beta. 10.15/Catalina should work on your MBPro. Is there an opportunity to install the Released version of Catalina on your MBPro?

  2. What version of Roon are you using for your Core? Roon 1.8 Legacy or the newer Roon 2.0, and what build number for either? For example, Roon 2.0 Build 1148 was released yesterday.

  3. 8GB of RAM may be a bit limiting for Catalina. Are you running any additional programs such as anti-virus?

  4. Have you tried uninstalling Roon from your MBPro and reinstalling a fresh copy? If so, do you have a backup created from within Roon you can use in case there is an issue with the reinstallation?

Hey Rob. I am locked into the beta version for the time being. The Roon version i’m running is 2.0 but it’s the build just before 1148. Currently running F-Secure via Spectrum and i havent tried uninstalling my current version of Roon. Could you please provide the backup instructions?

Brian, below is the backup guide from Roon directly on how to backup your database from within Roon:

Your music library/files are not included in the backup, only the Roon database and required ancillary files. However, you must backup from within Roon itself. Is your Roon Core stable enough to perform a backup?

How am I able to run a backup if Roon won’t even launch? Is there another way to access the backend?

Unfortunately no, the backups must be made from within Roon. I am tagging @support for assistance for you.

Good morning. Will anyone from @support be able to help me with this??

Hi @1brianhitch1,

Apologies for the delay here.

First off, do you experience this issue without any audio devices connected?

I recommend deeply refreshing the Roon database. If you don’t have a recent Backup and haven’t set up automated backups, you will unfortunately lose any custom DSP and Zone settings, and will similarly need to reimport your library. However, this step will stabilize Roon and hopefully allow us to access more precise diagnostic information to resolve any remaining issues:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

We’ll keep an eye out for your response.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.