My Roon does not play local files anymore

Roon Core Machine

Synology NAS

Networking Gear & Setup Details

Wired via Netgear router to Mac running macOS Catalina. No VPN.

Connected Audio Devices

Speakers of Mac via Roon for Mac.

Number of Tracks in Library


Description of Issue

After weeks of fun playing local files and Qobuz music, suddenly I cannot play local files anymore. It looks like they play but the play time does not move:

I still can play Qobuz music if I haven’t tried playing local files before that. After I attempt to play local files, nothing plays anymore. I have to quite the Roon app on Mac and start it up to get it playing again.

I have rebooted everything: Roon Core package, then the whole Synology NAS, then the Roon app on Mac, then the whole Mac. Still the same issue.

Roon on Mac can see the local files: I still can browse my local music, but I cannot play it.

Please help! Thank you!

Actually I found the problem:

The file share on the NAS where the music files are wasn’t mounted on the Mac. So the music was there (and can be accessed on the NAS) but not from the Mac. When I mounted the share it all worked again.

Two things seem strange to me:

  1. Why does Roon on Mac still show the albums if the files are not there for the Mac?

  2. Why does the Roon core (running on the NAS) not access the music files (which are on the NAS too) directly?

Can you post a screenshot of Roon’s Settings > Storage screen? Thanks.

you are, @Geoff_Coupe :

So you have defined the Watched Folder in Roon to be the Synology folder mounted on your Mac, as far as I can see.

If you want to access the Synology folder directly, then you need to edit the Watched Folder filepath (use the “3 dots” menu), and add a Network Share corresponding to the Synology shared folder directly.

Thanks. So you mean I add the Unix path to the music folder as it appears on the NAS itself (something like in my case: /volume1/Welten/iTunes Music/)?

No, that’s not the correct form for a Network Shared Folder. Please have a read of this article:

1 Like

Hi @hallo_leo,

Were you able to successfully add the network share using the instructions our moderators linked above? The tech team is on standby if you’re still having issues with local file playback.

It’s not possible to use network shares in Roon with Cores running on DSM7 (and higher). If needed, the share(s) has to be mounted by the OS (DSM7) and setup as local drive in Roon.

The OP said that the Roon Core is on the Synology NAS. If that is the case, why are they using a network share if the music files are on the Synology? At least they appear to be on the Synology based on what I see in the image showing the storage location.

Hi @connor

Thanks for chiming and sorry that I haven’t responded earlier. Haven’t sorted it out yet. Towards the weekend I will have a read through the FAQ and report back.

Yes, teh Roon Core is on the NAS and the music files are on the same NAS.

Trouble was the following: When I set up the system (from the Roon app on the Mac) it found teh core on teh NAS but asked me to tell where the music is. And that was the moment wheer – I think – I could only point to the NAS music files as a share on the Mac. Does this make sense?

I will fiddle with it again, but don’t know how to tell the Mac app that everything is on the NAS.

Why is this exactly? Asking because my Synology is currently on DSM6.2 and I was thinking about updating it to DSM 7. Roon is on ROCK if that makes a difference.

I don’t have a NAS to test on, but you should be able to select the directory on the NAS without going through the Mac. That makes zero sense to have to do. You should be able to add a folder from the NAS directly. Remember, the control apps running on a Mac, iPhone, or iPad are remote controlling the Roon Core on the NAS.

It makes a difference in the way that your Core is not running on DSM7 – so your Roon Core is unaffected by the changes Synology made to their OS and App /Store) infrastructure. You may have to ask Synology as for why they made those changes if you want to know it. Others can just guess. My guess: they were no longer willing to allow Apps to change the underlying system at will (potential security risks, makes work harder/impossible for the DSM support team).

Brief follow up, @Geoff_Coupe and @connor:

I manged to connect the music storage directly to the Core on the NAS. Yipee! So now I can listen on the Mac without having the music files mounted to the Mac.

What did I do?:

  1. In Roon on the Mac I disconnected my old storage folder (which were the NAS files mounted as a Mac share).
  2. I unmounted the Mac share.
  3. In Roon on the Mac I added the music files directly from the NAS. (Now they were offered directly from the NAS – I can swear I hadn’t seen this when I connected the my music the first time!)

All good now! Thanks for offering help!

I guess I am chopped liver… :wink:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.