Mytek Manhattan not seen or failed to initialize

SonicTransporter AP connected to incoming Spectrum router

Networking Gear & Setup Details

Connected Audio Devices

  1. Living Room system connected directly to Spectrum router via Optical Rendu to Mytek Brooklyn DAC+ - working well and consistently
  2. Bedroom system wifi to Auralic Aries Mini to iFi Neo iDSD DAC – occasionally need to restart Mini
  3. Studio system - Router connected by ~70 ft shielded cable to opposite side of house. Received by optical media converter [from Small Green Computer] to TrendNet multi switch, USB cable to Manhattan II.

Number of Tracks in Library

Description of Issue

Studio system - Router connected by ~70 ft shielded cable to opposite side of house. Received by optical switch to mutli switch, USB cable to Manhattan II. This system was working for about two months, but has not worked for about a week. There were occasional times it disappeared previously but it returned by restarting the switches. I have restarted both optical and muti switch as well as Manhattan, and even restarted incoming router switch.
Manhattan switches between inputs from AES from my RME Fireface UFX studio recorder, phono preamp, and CD player.

There is a device under Settings/Audio labelled Mytek USB but when I try to enable, I get message Device Initiation Failed.

Any thoughts?

Hi @Dan_Bode,

Thank you for getting in touch with your question. We’d be happy to take a look here.

As a test, if you temporarily disconnect the converter and switch, and connect the Manhattan II directly to the cable run will the Mytek appear on your Audio page?

A few hours after I posted this, the Manhattan showed up on both my phone and my PC. I had not done anything since writing the note, after trying restarts daily for about 5 days. It seems to be fixed, but I don’t know why or what to do if it disappears again. Your idea to bypass the optical converter and switch is a good idea to test.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.