NAA not seen by HQPlayer

Hi, just updated to the latest version of RopieeeXL and HQPlayer doesn’t seem to see the NAA anymore. I also added an Allo DigiOne HAT. Is it possible to run the HAT and USB output at the same time? I notice for the other items such as Shairport or Spotify I am able to select USB or HAT as output, but for NAA, there is only on/off.

Note, I am seeing the DAC and the DigiOne in Roon so it’s just the NAA is not showing in HQPlayer.


I’m experiencing a similar problem with my setup. The difference is that HQP server has never seen my Pi HQP endpoint. I have HQP NAA activated in RoPieeeXL on a Raspberry Pi 4b that is connected to my network via wireless (all Ubiquiti Unifi network gear). I have HQPlayer server installed on a machine with a lot of processing power. My music is stored on a NAS. I can see the Pi in Roon and can successfully play to it as a Roon endpoint. I just cannot get the Pi to show up in the “Settings/Output Device Settings/Backend/Output” drop-down in the HQP server program. Would love to understand why it doesn’t show.

HQPlayer does end-point control in a ‘similar way’ as Roon: it’s intelligent in a sense that it detects all available outputs (HAT’s, USB) and sends it upstream so you can select the output from HQP.

That’s the reason that there is no selection necessary.

Can you send me feedback?

I struggled to get HQP to see my Pi using Ropieee XL.

Couple of things that I fiddled with and tried that made it work; I initially used the web control panel to ‘upgrade’ from straight Ropieee to XL. I then did a full fresh flash of the SD card to XL and reinstalled. This seemed to fix it.

I assume too that you have selected Network as the input in HQP. As Harry says, at this point it then just automatically found the DAC.

Just covering off the obvious things also; have you checked the symbol on HQA to allow network control?

In my case, Roon seeing the RopieeXL as an endpoint and I can play to it. Issue is HQPlayer is not seeing it as an NAA. Could it be that for some reason, RoonBridge is taking “exclusive” control of the DAC and so NAA does not see the DAC and hence HQPlayer does not see the NAA and a valid device to play to? I suggest this because it seems my network is working properly given I can see the device under Roon.

Yes that could be the issue. You can simply test that by rebooting the unit and don’t use Roon but HQP strictly.

Hi, yes, I tried rebooting and I still cannot see NAA from HQPlayer. Just sent feedback b496804da9cadf8d. Thank you!

This is what happened to me having ‘upgraded’ Ropieee to Ropieee XL. A completely fresh install solved it…

I can also confirm that HQPlayer (version 3 could not see either of my NAA enabled RopieeeXL setups (using version 2.526) after updating Roon. However, on disabling one of my Pi devices in Roon and rebooting…HQP could then see the device.

On mine, I can play from Roon and Spotify and so it’s just HQPlayer not seeing it as NAA.

I tried this in my setup. HQP ONLY in RoPieeeXL. Unselected everything except this. Rebooted the Pi and looked for it in HQP server; still cannot see the Pi there. I have the network control icon selected. I also disabled the Roon bridge to my DAC.

Same here…have been trying various combinations all day and no luck.

Ok, can you guys send me feedback?

Hi, sent b496804da9cadf8d

Ok can you send me another feedback, but first make sure you run configure.
This can be triggered by going into the webpage and commit and save (no actual need to change a value), so I can see what’s going on when stuff is being configured.

Would be great if you, for test purposes, disable shairport-sync and only have HQP enabled.

Oh. And send the feedback without rebooting.

Here you go…committed changes and feedback is before rebooting: 5b183c4b7b2235a6. Only NAA is enabled.


Thanks @hammer.

I’ve pushed an update to the beta channel.
Can you try that? You can do that on the ‘advanced’ tab.

Let me know how it goes.

Hi, both NAA and Spotify works, but Shairport/Airplay does not ( I don’t see RopieeeXL as Airplay option). Sent feedback 31168cecd0e5c6fe. Thank you!

Im confused. I thought we were talking about NAA.