Nad ci580 Thoughts

Hi all,

I have never owned NAD products before. My AV fitter is recommending the ci580 as the heart of a multi zone system.

I am interested in any thoughts or recommendations. My house is quite open plan so zones will need to ‘play nice’ together.

Mqa is an added bonus but not sure that works under RAAT.

Thanks for any help,

@Sean_T You may want to check out this thread:

Go for it! Very happy with sound, integration, sync and also MQA with the ci580.

Thank you both.

I have decided to go for it. Any issues seem to get resolved and it seems a good ,and reasonably priced, solution for multiple zones.


How have you guys been doing with this. I see the one person with issues about the only being able to get one stream going. Was that resolved? I assume you are/can stream different music to each zone if desired? Can you also EQ each zone? Thanks

When I hit next on a song while using Roon to access the NAD CI 580 it starts playing the sing bbut then cuts out and either starts replaying or skips to the next song. Has anyone observed this behavior? i am running 3 CI 580’s to push music throughout the house.


I have had this a couple of times but was also occurring on my squeeze box garden zone as well as the 2 NADs. I ‘solved’ it with a reboot of my network , players and NUC.
Does it happen on local and external streams (tidal)?.

It appears it is happening on Tidal as well as my itunes library. I will try rebooting everything this weekend. Is there a reason why this is happening? I am running a NUC with a 4 core i7 2.7 Ghz, 32GB of RAM and Samsung 970 EVO 1TB - NVMe PCIe M.2 2280 SSD. This is directy connected to a gigabit switch, which the NAD CI 580’s are also attached too. the internet is 500 Mbps and is connected to the switch through a 10Gbps optical link. There shouldn’t be any issue with speed.

Similar set up to mine in terms of NUC and bandwidth.

Could not identify any obvious problem and it was intermittent. It has not happened for a while now on mine, not sure if this gives comfort. However as seemed to happen at same time on nads and squeezebox do not think it was a nad specific issue.

Rebooting seems to have fixed the issue but now my ios device cant connect. Any solution to that?

Sounds like a networking router connection issue between NUC ,zones , and front end (ioS).

Not really much help but maybe raise with the roon support team to see if the logs show anything obvious. Networking not an area I know enough about

Anyone having issues with the new BluOS update? Roon seems to be having trouble finding some of the rooms and is also dropping audio in certain rooms randomly. the music plays fine through BluOS so the issue has to be with roon interacting with the NAD. Everything worked fine yesterday. I tried rebooting everything and It worked for a bit but then stopped working again.

Hi, I am having the same issue …

Were you able to figure out a solution or did NAD help?

I have been away from home for a while so not had a chance to look into it. When have been home just been using the bluos interface. I am not sure if this should be raised to roon or NAD??

Probably to both. I have sent the logs to NAD but havent sent anything to Roon yet.

I will do the same this weekend

Any luck on getting it to consistently work? I can run spotify or the Blu OS app and they both work fine. Roon still drops zones.

I have updated roon and rerun the nad update and then powercycled everything again.

For the last few days roon has been working ok to all my zones except the ones I grouped in BluOS. I ungrouped these and applied the grouping in Roon. Seems to work ok at the moment…I will let it be for a while. Any luck?