NAD M32 - random rapid stutter

Core Machine (Operating system/System info/Roon build number)

OS: Arch Linux x86_64
Kernel: 5.9.14-arch1-1
Motherboard: X399 DESIGNARE EX
CPU: AMD Ryzen Threadripper 2970WX (48) @ 3.000GHz
Memory: 64GB
Roon build: 756

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Intel I211 Gigabit Network Connection - Ethernet connection built in on motherboard

enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
link/ether b4:2e:99:33:c4:82 brd ff:ff:ff:ff:ff:ff

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD M32 over ethernet connection

Description Of Issue

When playing music through Roon I get random stutters in the sound. The sound is reminiscent of playing a clean record that suddenly runs into a dusty part of the track and the needle starts bouncing. This only happens when I play through Roon. I have tested both MQA and non-MQA FLACs. I have tried playing tracks from the TIDAL connection as well as local files. When I connect Spotify or BluOS Controller to play music on the M32 it works without these problems. I have also tested installing a separate core (build 756) on a Windows 10 machine (the same machine where I run the Roon client) and I experience the exact same issue when connected to that. I have also tested to play to my headphones on the computer (Sennheizer GSX1000 soundcard) from Roon and that works fine too. Only from Roon to the M32 is a problem. However that is how I mainly want to play music so that is still a big issue.

Hi @Hakan_Agren

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Since this is only hapening when using the M32 with Roon, have you contacted NAD about this? Have they provided any feedback on what might be happening?

Just to confirm, is the M32 connected by Ethernet as well?

Hi Dylan, thanks for your response. Yes it is connected with Ethernet, hooked up to a Unifi 8 port PoE powered switch. I have not spoken to NAD directly but yesterday I went to the dealer and talked to them about the problem. They are escalating the question in-house and I’m waiting for their response to the issue.

Keep in mind that I have so far only been able to recreate this problem when using both Roon and the M32 together, and the problem occurs with TIDAL MQA as well as local FLAC files in the library as the source. I have not tried TIDAL non-MQA but since local files have the same issue I don’t believe the source is the issue.

Best regards,


I want to post an update here to inform how the issue was resolved. First what wasn’t wrong that has been suggested in other ways than in this community:

  • High load on server, hardware error on M32, network latency, M32 and/or server needs to be rebooted.

None of those things were the cause and some not at all relevant even. What did eventually help was to dig into the menues of the M32 and do a factory reset of the BluOS module. I don’t know what actually caused the problem and turning off and on the amplifier helped, even taking away power for a few minutes did nothing. But a factory reset did the trick just fine. It’s a bit unsatisfactory because I don’t know what actually caused it and why it showed up only with Roon as the streaming source. If does feel very good though because now I can use Roon as the player again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.