NAD music server not recognized by Roon [Solved]

I have just downloaded the controller app to my 2012 Mac Book Pro (OS = High Sierra ) and paid the Roon subscription fee. Roon version is 1.5 (build 323 64 bit. My music is stored on an NAD M50.2 music server, which is “Roon Ready” and has 2TB of storage with about 12,000 music files so far.

I found I needed to disable my McAfee firewall to use Roon. Likewise “remote connections” is enabled. Unfortunately, Roon doesn’t seem to see the NAD M50.2 on my Wifi network, so I guess “Network Connectivity” is what is at issue. My router is an Airport Extreme and the NAD Mf50.2 shows up in the Finder.

Hello @David_Waring,

Thanks for contacting support, I’d be happy to take a look over the situation you’re describing and suggest some possible troubleshooting steps.

Yes, you are correct in your assumption that for Roon to work properly, there must be specific firewall rules in place to allow both the Roon App and RoonServer to connect to devices. As for specific instructions on how to set that up, you would need to refer to McAfee’s website and open these specific ports.

You have mentioned that Roon doesn’t see the NAD on the Wifi network, does it see the NAD when you are connected directly through an Ethernet cable to the Router? If so this could indicate that the setup of the Airport Extreme is not allowing the connection to the NAD.

Furthermore, you have mentioned that you are able to access the network share from Finder, does it also list the specific IP address of the NAD in Finder? If so I would like for you to try the following:
• Please open your Roon App and navigate to Main Menu -> Settings -> Storage -> Add Folder
• Press Add Network Share
• Manually input the same IP Address/Hostname information as your Finder window
• If you did not set a Username/Password yet you can leave those blank
• See if you can connect and access the music folder that way

Please let me know if any of the above steps remedy the issue you are facing and we can continue from there.


Hi Noris. Thanks for the prompt response. I know the IP address of the NAD and will attempt the final fix you suggested over the weekend, If that doesn’t work out I’ll try the other solutions. Either way, I’ll get back to you with a status report. -David


Thanks David, looking forward to hearing your progress on this after you have a chance to try my suggestions!


Hi Noris, As hoped, the IP suggestion seems to have worked and Roon is busily adding files to the Library and providing metadata. Your expertise is really appreciated. If I have further questions, should I open a new thread or reply to you? -David

Hello @David_Waring,

Glad to hear that my suggestion worked, happy to help! I will be closing this thread as it solved the current issue at hand but if there is anything else going wrong please feel free to open another support thread. Until next time, take care and enjoy!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.