Naim Uniti Core and Roon


(Stephen Wright) #1

Setup:
Roon v 1.4 build 294 64-bit.
Roon Core (on a fully updated Windows 10 on an i5, 16GB RAM, wifi-connected.
Wifi network is based around a new Netgear Orbi RBK53.
Music is stored on the Naim Uniti Core (four months old, FW updated last week), connected by an ethernet cable to one of the Orbi wifi satellites. The Core is cable-connected to a Naim 272 and amplifier, and everything works well with that system.
~10000 tracks, ripped on the Naim Core and stored in a 2 TB SSD in the device.

The issue
I’m not an expert at streaming!
Roon Core is on the i5. It doesn’t see the Naim Core when I direct it to find the music via a Network Share. I’ve tried a couple of things I’ve read about (e.g. around variants of: smb://uniticore417945/music, or alternatively using the IP address). I get no connection at any stage, and either a message of Invalid Path, or the beginning of an attempt at a connection followed by “Could not connect to share: unauthorized”.

The Windows machine can see the Naim Core in File Explorer, and Windows Media Player can access and play the music. Other network streamers (two*Roberts RS1) find the Naim Core easily on their own without needing to try out innumerable guessed Network Share paths, and play the music just fine. So, there appears to be no fundamental network problem. The set-up described above was working some time ago until I had - for other reasons - to reinstall W10.

My intention is to use Roon particularly on an ehternet-connected SOtM sMS-200 music server, feeding an external DAC and into other Naim gear. But first I have to get Roon Core to talk to Naim Core…


(John B) #2

nothing useful to offer I’m afraid but a shout to @support may get some help.

.sjb


(Paul) #3

@Stephen_Wright To get the right network path for Roon to see my music files on my Vortexbox NAS, I had to type what was shown in the address bar when I looked up my Vortexbox on my network, Eg, \\vortexbox\music\flac. Note that I had to use reverse slashes, not forward slash. There should be two slashes in front of vortexbox in the above example, but for some reason it keeps only showing one when I type them here.

** now edited for correct number of slashes:grinning:


(Geoff Coupe) #4

It’s a side-effect of the Discourse software used to power the forum. You need to type three slashes to get two displayed…


(Stephen Wright) #5

Thanks to all! I’ve tried every variant of slash I can think of, together with different name formats (IP address or known name…).
Perhaps what puzzles me most is that using Roon leads the user into a situation where these different options to access the storage are necessary. Why can’t Roon have a search function that works (like my other music streamers) without needing sequentially to try out numerous address formats before hitting on one that the system likes? I’m new to this and it would be nice if it was user-friendly and functional. Meanwhile, I just want to get the thing functioning, or I’ll have to use a different system…


(simon arnold) #6

Plus one for above.


(Eric Stewart) #7

Hi @Stephen_Wright ------ Thank you for the report and sharing your feedback with us. Sorry to hear of the troubles here.

Moving forward, based on your report it sounds like you can successfully access the Uniti Core via Windows explorer. If that is indeed the case you should be able to click in the explorer window and copy the path, which in turn can be used when trying to mount the share in the application.

As you can see below in my screenshot, this is a picture of my NAS device being accessed using the method as mentioned above. I select the folder I want to mount (in this case it’s “downloads”), then I click in the bar at the top of the window, and copy the path:

image

If this is what you are currently trying to do and you are certain that the username and password are correct, may I kindly ask you to give the procedure another shot and let us know the time when the failure occurs (i.e you receive the mentioned error message). Once I have this information I can go ahead and enable diagnostics on your account so our tech team can try to get a sense as to what could be causing this behavior.

-Eric


(Stephen Wright) #8

Hi Eric

Thank you for this! I don’t know whether it’s significant, but in Windows Explorer on one of my PCs (not the one with Roon Core), I can see the Naim Core as both a Computer (where I can copy the network path) and as a Media device, whereas the Roon Core Windows machine can only see the Naim Core as a Media Device (and I can’t see how to copy the network path). Whatever.

I fiddled around this evening with Homegroup and Network Settings, without apparently achieving anything at all. Then I tried to connect Roon Core to the Naim Core… and it worked. This was using exactly the same drive address, typed in, as the last couple of days (i.e. \uniticore417945\music). But it only worked for a while, enough to load ~100 albums. Then Roon dropped the album list. When I looked in Settings > Storage, the Naim Core was there but listed as "This drive is not available. Check the drive, or edit the folder ". I tried putting the Naim Core out of standby (that presumably should not have any effect, otherwise music streaming to any of my devices would often be disabled…), and also rebooted the PC housing Roon Core. The Naim Core still showed as not available. I removed it, tried to reconnect to it and got the usual error message from the last couple of days - “Invalid network path”.

I think I’ve used (= wasted) enough hours now, more than a dozen, on what should be an automated task taking a few seconds within the application. If it were possible to escalate the issue to Tech Support, that would be handy for me. I’m on the free Roon subscription at the moment, but will have to look for another streaming solution unless the product can be made minimally functional and stable.

Steve


(John B) #9

It would seem from this thread that perhaps it is an issue on Naim’s side.

.sjb


(Stephen Wright) #10

Thanks for passing this on. My response is: maybe. The Naim here is essentially a brand-new device. That indeed doesn’t prevent it from being defective - but it works for every other functionality, so Roon is the standout.

In fact, I’ve given up on Roon. The software is expensive for what it does, and I’ve lost more than a day trying to sort it. The company’s business model consists of putting the application into the market, hoping, and getting customers to do the trouble-shooting and quality control via the forum. Some people may think this is fun, but I don’t. I can work as a consultant, and my day-rate is rather more than the cost of this app - which means that the overall apparent cost of the software can be much more than doubled in reality. Passing the blame between Roon and Naim is not productive - for the customer.

Steve


(John B) #11

Just trying to help, Roon isn’t for everyone obviously but I wouldn’t agree with your characterisation.

Roon and Naim provide nearly all my musical pleasure but neither are perfect, you are picking me up wrong if you think I’m trying to pass the blame between them, I was just pointing out one possible solution. I have a good friend who uses Naim Core with Roon but it does appear that pointing Roon at a Naim core is not a simple intuitive process.

It would be useful perhaps to have details in the knowledge base @Geoff_Coupe ?

.sjb


(Stephen Wright) #12

@.sjb
Absolutely no disrespect intended towards you - really, thank you for the effort. My problem is that I could return an otherwise perfectly functional Naim Core to the manufacturer, and I’m fairly certain that they’d find nothing wrong. Meanwhile, days more messing around, and the costs of shipment etc… I had already been in touch with tech support at Naim and they felt the problem lay with Roon (on balance - buit what would I know? - I’m inclined to agree with them).

For me, life is too short, so I cut my losses before taking a subscription - the trial period was just that, and not a success.

Steve


(Geoff Coupe) #13

It would, but I’m not best placed to write chapter and verse. I don’t have any Naim kit, so it would be a case of the blind leading the blind here.


(John B) #14

I was calling you from the point of your title as KB editor?

Perhaps giving @mike a nudge in this direction?

.sjb


(Daniel Beyer) #15

Putting Roon aside, If the issue started after a re-install of Win 10, and you still cannot see the Naim as a computer, then there is something amiss with the computer itself or the setup. You might verify that SMB1 is turned on (1) and you might download the network drivers from the hardware manufacturer instead of accepting whatever version Microsoft installed. And see if this corrects the issue with not being able to see the Naim as a computer.

(1)
Go to Control Panel > Programs and Features > Turn Windows Features on or off > check or uncheck the box for “SMB 1.0/CIFS File Sharing Support”


(Ged) #16

Have you tried connecting the roon core via a wire?
Coming from a support background, it was working until I… made me shudder :wink:


(Stephen Wright) #17

@Rugby

Thank you. SMB File Sharing Support wasn’t in fact turned on (is this a characteristic issue? Perhaps there should be something about it in the configuration notes). When I put SMB on, and put in the full path to the Naim Core’s music store, it finally managed to connect. It had done this some months ago (even before I fiddled with SMB, which I never knew existed…), only to lose the library a bit later, but this time it seems to have held on. I thought at first that I hadn’t gained a huge distance, because for hours Roon on my phone wasn’t connecting to the Roon Core. Then, suddenly, it managed it, and then I was able to connect to the streamer in the system (a SOtM sMS-200). So far, so good. I hope it hangs on in there.

Thanks again.

Steve


(Daniel Beyer) #18

Enjoy the music. Microsoft in their wisdom decided to “unenable” SMB 1 support during one of the Win 10 updates. My guess is that when you re=installed windows, the updated version turned off SMB1 support.


(Stephen Wright) #19

OK, thanks - a bit peculiar though since the W10 reinstall was before I had some success with a temporary library download. Never mind, I couldn’t care less as long as it stays working. Maybe a subsequent update? Who can tell…

I’m grateful that you helped.

Steve


(Stephen Wright) #20

@Rugby

It got a bit worse after my modest success. 24 hours after the PC acting as Roon Core downloaded and set up the Library, it promptly kicked it all off (as it did a couple of months ago, the reason I gave up then on Roon). When I investigated, after a fair bit of hassle, I found out that the “SMB” situation is more complex than I had thought. I hadn’t noticed that the “Turn Windows features on or off” flag has three tick-boxes - the first of which is “SMB 1.0/CIFS Automatic Removal”. Understandably, when you see that, it’s obvious that Windows promptly disables SMB a little while after it has been enabled in one of the other two boxes. Doing some browsing, SMB 1.0 has been “deprecated” by MS since 2014 (nothing like what I said about it over the past few hours). It has been replaced by SMBv2, though there is no sign of that version that I can see on my machines. Needless to say, I have unticked the “Automatic Removal” box; at that point, the music server (Naim Uniticore) reappears as a Network Infrastructure device (it has been there throughout as a Media device, which fooled me for a while).

Has nobody else on Roon ever encountered a problem with streaming devices which depend on legacy, unsupported features???

Let’s see whether it sticks now, or whether some other problem emerges.

Steve