Naim Uniti Core not seen

Roon Core does not pick up the Uniticore automatically, how do I point it to it.

Uniti Core needs to be added in Settings > Storage, like any other SMB share. The basics are here.

1 Like

any idea what that might look like?

Sometimes it can be hard to comprehend how difficult this can be for someone coming form an indigenous ecosystem like Naim.

.sjb

Although this is an old topic I have the same issue - my Roon Nucleus can’t find the music folders on my Naim Uniti Core. Did anyone figure out how to resolve this issue?

David Lavery

Is the network share on the core active? Can you navigate to your music folders on it via a computer using finder or Windows explorer. If so the the path you use to do this is what you should add in Roons storage tab.

When I try looking at the Naim Uniti Core using a web browser I do so by entering the IP address but all I get is a black screen. My Uniti Core is ripping CDs to its music folder fine and I can see the ripped CDs using the Naim App and can play them on my Naim NDX2 or Naim Muso. So as far asI can see the Uniti Core is working fine but can’t be accessed by my Roon Nucleus. My Uniti Core’s name is UNITICORE followed by three numbers. Based on a screenshot posted by someone on a forum I tried entering the pathway as follows -
\UNITICORE******._smb._tcp.local\Music
But the Roon App couldn’t follow the pathway.
Any advice would be most welcome.

Ps I should add that I CAN see the Music and Downloads folders on my Naim Uniti Core by using Finder on my MacBook but it doesn’t show me the pathway address to the folders. How do I access the pathway information once I can see the folders using Finder?

There is no web access to it so it won’t work in a browser. I don’t have a mac so don’t know how you trace the share that your seeing in finder. If you have not already perhaps ask on Naims forum as there will likely be more uniti core users on there.

I had no problem connecting the Uniti Core to Roon, all of the required information is available through the Naim App.

Firstly, you’ll need to find the IP address of the Uniti Core. You can get this information from:

Settings Menu > Other settings > Network settings

Make sure DHCP is off otherwise the IP address changes every time the Uniti Core loses network/power.

Now you’ll need to put the IP address you found in the app into Roon, the format of the Uniti Core is as follows:

smb://<IP.ADD.RES.S>/MUSIC

The default username is admin, as is the password, and the workgroup is NAIM (capital letters). If this doesn’t work you can find this information in the Naim app again:

Settings > Manage Music > Configure Music Shares > Share Settings

If this doesn’t work you may need to send screenshots on private messages and I’ll attempt to assist further.

2 Likes

I don’t have a Core, but when I set up my Unitiserve in Roon, I recall that for some odd reason, selecting the whole music folder was not the thing to do. For some reason, what you had to do was to select any individual (album?) folder from within the music folder, and as soon as that was done, the whole music folder was found by Roon.
I thought this was pretty odd at the time, but it worked, so maybe it’ll work for you too, as the file structure in the Core is similar.

Thanks for your response. I finally got this sorted last night. After looking at lots of forums and (often misleading) suggestions as to how to enter a folder pathway on a Naim Uniti Core, I finally found one that worked. In my case I entered the following pathways (where ****** represents the six digits in the name of the Uniti Core) -

smb://UNITICORE******/Music

smb://UNITICORE******/Downloads

Once these pathways were entered the Roon Nucleus immediately started to scan the music folders. By today all my music on the Uniti Core had been scanned and is playable on my Naim NDX2 using the Roon Remote App.

After faffing about for several days before stumbling on a solution I must say I think both Roon and Naim could make this a lot clearer.

Thanks again for taking an interest.

3 Likes

Good to hear you got there in the end!

Thank you! Really useful post. I agree - it’s ridiculous that, on a piece of software that sells itself as making things easy, that we should have to go to such lengths. Reminds me of my Windows days

I had a repeat of this issue earlier this week when Roon could no longer see the music on a Melco I have now added to my system. Again the issue was with the path to the Melco’s music folder. It had been working fine for many weeks and then suddenly it stopped working. It took me a number of hours - many of them going into various cul de sacs on Internet forums - before I got some assistance from Phil Harris (who now works for Melco and is always very helpful). The problem seemed to be that I had changed the Melco’s “friendly name” and Roon was still looking for it under it’s previous name. I have no idea why the issue only showed up this week - the name change was done weeks ago - unless it was due to a domestic power outage that occurred at the weekend? I find that when there is a power interruption inevitably some gadget or other falls off my network and has to be prompted to rejoin it. Room could I think be somewhat clearer as to how to enter the path to a NAS music store - they tell you the basics but leave out what to enter for the username and password. I find it very frustrating the ‘Help’ resource these companies provide is to direct the customer to a customer forum - all too often that is a recipe for the blind leading the blind! Anyhow, rant over!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.