Naim Unity Nova firmware updated now screen does not work

I did the new firmware update that adds Tidal connect. The next time I went to turn it on the screen is blank. The unit still works but you just can’t see anything on the screen. I found a setting in the app about being able to turn the screen on and off but that isn’t fixing it. I can select inputs and it all seems to work just no screen. Seems like it must have been triggered by the firmware update, it has been working perfect and used daily before.

The same on NDX 2, since the latest 3.7 naim firmware when skipping tracks or changing album the screen stopped working properly in roon.

At the moment I do not know if it’s Naim fault or roon side. But I think is on the new firmware. You can post on Naim forum the issue.

Thanks for the information, I won’t update my Atom yet then.

Never had this issue with mine and I was a beta tester for this version. I would try a factory reset to see if it helps if cani often unstick issues with updates. You’ll have to set up your favourites and rename any inputs though.

Anyone else have any ideas. Screen still not working. The functions of the machine work but I have to access changing inputs and seeing the volume via the app. I tried to get help from Naim directly but they just hung me out to dry and said take it to your local dealer. I don’t have a local dealer I bought it from an online dealer. Not very happy with Naim they won’t return even an email and help me setup some kind of online return. Seems highly unlikely that the firmware update did not cause this. I’ve never had an issue with my Nova before and then the screen doesn’t work the first time I use it after firmware update? I’ll never do another firmware update on anything ever again without doing a lot of research and waiting for possible bugs to be worked out. A firmware update totally melted down my Kef LS50W speakers years ago.

Have you tried a full factory reset? First thing I would do. You can do this by powering it on from cold and holding the play pause and source buttons for about 5 secs.

Naim like most companies always recommend you to go back to your dealer to sort out problems first. Its the dealers responsibility shop based or online to sort this out as the warranty goes through them to Naim. I have had great service from them when one firmware causes me some issues via the forum. Their product manager helped my on a bank holiday.

I did do the full factory reset a couple of times. I’m pretty sure it took because all my custom settings were erased when it got back up and running. It’s also kind of odd it makes a sort of thud noise when I turn it on now. It never did that before. I have an Atom and Mu-so V2 here as well. I sure wouldn’t do another firmware update on those now after this. I’m a little displeased by Naim. I’d prob never buy another product again. I’m more likely to get this fixed and get rid of the Atom and Nova and find another company better to deal with. I will try the Naim forum and see if anyone has any other advise. It’s just kind of BS that I should even have to pay a shipping charge for something that is 100% their fault and they just blow me off.