NAS QNAP/Synology DSM 7.1-42661 Update 2 (2022-06-01) problem

Since I updated my Synology NAS server to “DSM 7.1-42661 Update 2” the update also forces the “Advanced Media Extensions” package to be updated to version 2.0.0-1017, Roon does not play music anymore.

Advanced Media Extensions allows you to play HEVC (High Efficiency Video Coding) and AAC (High-Efficiency Image Container) files on your Synology NAS. Without AME, other software packages such as Synology Photos, Video Station, and Audio Station may not be able to convert some files to the format needed for use.

Codec Pack
Supported Codec: AAC / HEVC
Current version: 1.0.0-50001
Last update time 2022-06-01 09:21:00

The roon package is this one:
from Synology – RoonOnNAS

KO Random problem after reinstall Roon on NAS …
Some songs don’t play and then Roon doesn’t play anything after or random

Hello @Rene_Demellayer and welcome to the forum.

Maybe the same problem as here:

Did you actually have one of the two specific use cases that required you to update to Update 2? If not, Synology specifically noted that “The system evaluates service statuses and system settings to determine whether it needs to update to this version.” These are the conditions:

  1. When an SSD’s firmware version doesn’t support the S.M.A.R.T test, the system will disable related functions.
  2. Fixed an issue where the out-of-band port couldn’t function properly when users configured Link Aggregation with only the ports on the external network card.

Otherwise, you should be on Update 1.

Thanks BlackJack, I will investigate in that direction.
I tested the track playback starting with :

Format: MP3 ok
Format: ALAC ok
then AAC format KO , I have to quit roon (client) and restart it to be able to play MP3 and ALAC formats again.
the AAC crashes the playback…

Probably related to the update of : “Advanced Media Extensions” package to be updated to version 2.0.0-1017

So, you did not provide the ffmpeg decoder for the RoonServer package as described in the posts I linked above?

1 Like

Thank you BlackJack,
I had to put a version of ‘ffmpeg’ in the directory (RoonOnNAS/bin/) everything works now.

1 Like