"Native" option no longer available

Core Machine (Operating system/System info/Roon build number)

Server with Ubuntu 18.04.3 LTS / Roon 1.7 build 505

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DAC Matrix X-Sabre Pro connected via USB

Description Of Issue

I’ve the dac Matrix X-sabre Pro connected via usb to the core. “DSD playback strategy” has always been set to “Native” but today i realized that this option is no longer available. I tried to restart the core and the dac, disconnect and reconnect the usb cable, but nothing has changed.
What happened?

Hi @Daniele_Piancastelli,

Apologies for the delay here! I spoke with the team about this, and we are hoping to gather a little more information here.

Is the DAC firmware fully up to date? What is the firmware version?

Is there any change if you use a different USB cable? If you reboot the Core or the DAC is there any change?

No problem for the delay.
The firmware is updated to the latest version (V 1.82)
I tried to change the usb cable, restarting both the dac and the core several times, but nothing…

Only two things:

  • I tried to install a VPN but it didn’t work with roon, so i removed it from the server. However, i don’t believe that this process could have created problems.

  • The other thing is that when i realized that there was no native mode are avaible, i had just transferred a track from my smartphone to my main zone where the DAC is connected and the song, instead of continuing to play, was interrupted.
    I had to click on “play” to resume and in that moment i realized that the word “Native” no longer appeared on the display of the dac

Last thing: on my Core run some roon extensions

Hi @Daniele_Piancastelli,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, I’m hoping you can do the following:

  • Disconnect the DAC
  • Reboot the Core machine
  • Launch Roon
  • Connect the DAC and make a note of the time you do so

Then respond here with that time in your local timezone, and I’ll make sure we review the diagnostics related to that timestamp.

Thu Dec 12 19:45:51 CET 2019

@Daniele_Piancastelli, I have noticed the same thing with a Mutec MC-3 in my chain.

Thanks, @Daniele_Piancastelli!

Diagnostics have been enabled. I’ll follow up as soon as I have feedback from the team on this.

Hi @Daniele_Piancastelli,

The team has asked that you please send us logs from the Core machine. Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?

We need both RoonServer logs and RAATServer logs (RAATServer is found similar to RoonServer logs but they’re in the RAATServer folder).

Let me know if you have questions about this!

Hello @Daniele_Piancastelli,

Detection of Native DSD for USB DACs is handled in the Linux kernel. When RAATServer is started it queries ALSA for the format support for connected devices. Roon uses the list of supported formats reported by ALSA to set the DSD support as well as things like max sample rate.

Looking at the logs you shared with us, the ALSA component on your Ubuntu instance is not reporting Native DSD support when a format probe is called. Thus, it is not possible for Roon to use the ALSA driver to play Native DSD content to the device.

I am unsure what could have caused this to occur. I tested our in-house Matrix Audio X-Sabre Pro MQA on Linux and I am able to play Native DSD without issue, even after multiple reboots, so we know that it works. I would start by updating your Linux Kernel to the latest version.


It works!
I upgraded the kernel and now the “native” option is back
Thanks :wink:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.