Need help getting roon working [Solved - Graphics Drivers]


(James Coyle) #1

@support ROON INSTALLATION ISSUES

Jim Coyle [email deleted]

64 bit Windows 10 (v.1809) in a LENOVO 20250

Laptop has NVIDIA GT-745M and an Intel 4600 card

OPENGL 4.6 installed

RAM 16GB

NV Storage HGST hard drive 1TB (Drive C:)

NV Data Drive WD (external) 3 TB (Drive D:)

We downloaded the 64 bit version. Installation went well but problems cropped up during setup.

Start Roon

Finish

I agree

Use this PC

LOGIN

Add Music

Plugged in D Drive. ROON found it and offered a path to it

Several seconds later, a blue circle came up and NOT RESPONDING showed at the upper left of the ROON screen.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

In perusing the Windows logs, we didn’t see any errors posted for this installation attempt. There were

however, errors from other attempts to install.

Just tried installing using the same downloaded file only with the D: drive connected from the start.

The installation went fine until we added a folder (D:) and then we got “not responding” in the upper left. Didn’t see any corresponding APPLICATION logs but there were DCOM errors in the system error log. The error included code 10016 on all 4 entries. Thanks


Roon crashes on startup, more info
(Andrew Cox) #2

Hi Jim,

Roon Support will be along shortly to get you sorted, but in the meantime I’ve edited your post to delete your email address. Bots often scan Forum posts collecting unsecured email addresses to add them to spam lists, so best to use PMs to inform others of email addresses.

Roon will have your email from your account, but you will get a response to this thread online rather than by email.


(Ged) #3

Perhaps try putting a few music file son the C: drive and installing, without attaching the D: drive and see if the install finishes. Then add D:.


(Noris) #4

Hello @James_Coyle,

Apologies for the delay in getting back to you here, can you please provide some screenshots of the error you’re seeing and a snippet of the system error logs?

I looked up the DCOM errors and have found this article referencing it:

It appears to be some kind of permissions issue at first glance but I have requested that the QA team take a look at this matter and I will let you know what they say.

Thanks,
Noris


(Noris) #6

Hi @James_Coyle,

One other idea I have here if the issue still happens after following that guide would be to login and set up Roon first and then after everything has settled add the additional storage location. So this would be a bit different than adding the media locations on the Roon startup and would have to be done in Roon Settings -> Storage Tab. Please let me know if that changes anything.

Thanks,
Noris


(James Coyle) #7

Hi @support

I have been trying to get roon working about 3 week now and on last support email Noris replied that it looks like my laptop is not giving permission given the error codes I am getting in the log. Noris said this has been passed on to QA but asked if I could send screen print of log. and any other pertinent information please see the attached. Hope this can help me get up and running. Thanks, Jim


(Noris) #9

Hello @James_Coyle,

Thanks for performing that test. Can I please ask you to manually send us the logs from that machine using these instructions? If you don’t have dropbox or google drive just let me know and I can provide an alternate upload method.

After sending us the current logs I would also try updating Roon to version 1.6 which we just released today and see if it has any effect. I have scheduled your case to be discussed with our dev team later this week and will let you know what their thoughts are on this matter.

Thanks,
Noris


(James Coyle) #10

@support
Hi, I have been trying to get roon up for over 3 weeks, finally my IT friend and I just wiped clean my hard drive and reinstalled the most recent version of Windows. We verified I had 4.3 openGL and then tried to install roon before adding any other apps. I got past select my folder and continue, I typed in my email and then before I could get my password in it crashed and I got the BSOD and the laptop rebooted. I am trying to get you the log but am having trouble. I canLog Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 1/23/2019 9:00:33 AM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: SYSTEM
Computer: DESKTOP-7DVAS66
Description:
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
Windows.SecurityCenter.WscBrokerManager
and APPID
Unavailable
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:



10016
0
2
0
0
0x8080000000000000

846


System
DESKTOP-7DVAS66



application-specific
Local
Launch
Windows.SecurityCenter.WscBrokerManager
Unavailable
NT AUTHORITY
SYSTEM
S-1-5-18
LocalHost (Using LRPC)
Unavailable
Unavailable


(Noris) #11

Thanks for providing that info @James_Coyle, I have added it to your case and will be sure to let you know once I have discussed this issue with the devs.

Thanks,
Noris


(James Coyle) #12

@support

Hi I am sending more information that Noris requested to try and help me get roon up and going. Last error log he said it looks like my laptop is not giving permission to install without crashing. Please see attached.
Below, please find link to Roon log after failed install.

https://1drv.ms/u/s!Arkz5IdNndIQhBd5MboRyWNZpbXG

`


(Noris) #13

Hi @James_Coyle,

Please try to keep all of your posts in one thread (this one). I am not seeing any crashes listed in the log file you sent over, can you please zip up the entire Logs directory and send it to us and not just the primary log file? You can use these instructions to navigate to your Logs folder:
https://kb.roonlabs.com/Logs

Thanks,
Noris


(Noris) #14

Hello @James_Coyle,

I spoke to the team today about your case. In addition to sending us the log files over, it would be a good test to verify what the behavior of Roon is like if you try using RoonServer instead of the All-in-one package. RoonServer is identical to Roon except that it doesn’t have a User Interface, so you will need a Roon Remote to control it.

Please send the logs over and give RoonServer a try and let me know how it goes!

Thanks,
Noris


(James Coyle) #15

@support Thanks for your suggestions. Installing Roon Server also failed during installation. Here is a link to the ENTIRE ROON LOG FOLDER. There is only one log in the folder. https://www.dropbox.com/s/7ss1w8i6p0dtcfi/Logs.7z?dl=0 This may be because the install crashes before Roon is completely installed.

Once again, thanks for your time and I look forward to having Roon install on my machine.


(Noris) #16

Hello @James_Coyle,

Thank you for submitting those logs. I am not seeing anything strange on my end so I am passing them to QA for review. I will let you know once they respond to my request for analysis.

Thanks,
Noris


(James Coyle) #20

Hi Noris, it has been a few days and it’s been almost a month that I have not been able to get roon installed. I have gone as far as wiping my drive and reinstalling the latest windows 10, verified all drivers are current snd tried all supports suggestions thus far. (See history) Not sure what the problem is as every program I have installed and used with no issues including JRM, TIDAL, Fidelizer etc. I even attempted to install ROON first after wiping and reinstalling Windows 10. Please advise. Thanks, Jim


(Noris) #23

Hello @James_Coyle,

Apologies for the frustration here, I know you have tried a lot of troubleshooting already and this has gone on longer than either of us would like. I had a meeting with the team today regarding your case and we believe this is the best way to proceed here:

  • Can you confirm that Roon is stable without adding the D: drive and running just off of C: for a day? Does everything work as expected with no crashes?

  • You mentioned that you have both NVIDIA and an Intel GPU for that laptop, if you right-click on desktop -> NVIDIA Control Panel -> Program Setting, what GPU is Roon listed as using? You can select the type of GPU used and it should appear in a similar menu:


    Note: If Roon is not listed as an option there, please add it using the “Add” button and try both graphics card settings as this may help.

  • Does Roon still have issues if you add other types of media, such as a thumb drive? This will also give us a good data point.

Please let me know if any of my above suggestions help here.

Thanks,
Noris


(James Coyle) #24

@support
Hi Noris, Great news, our determination paid off. We had tried all your recent suggestions and still no luck. After having completly wiped my drive and reinstalling windows 10 We never thought to go back and check the latest drivers were installed thinking that the most recent download of the current windows 10 would be enough, well it wasn’t and after updating the drivers it NOW WORKS! Now comes the fun if learning all the ins and outs. Thanks for all your help
Jim


(Noris) #25

Hello @James_Coyle

Glad to hear that the issue was due to not having the latest drivers and that installing them resolved the issue! Thanks again for contacting us and I hope you have a great Roon experience :headphones:!

Thanks,
Noris


(system) closed #26

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.