Network connection issue

Core Machine

Roon Nucleus Rev. B.
Firmware 1.0 (build 227) stable /, version 1.8 (build 790) stable.

Network Details

Netgear Orbi RBK 53. Roon is connected to one of the satellites.

Audio Devices

Description of Issue

I have bought Nucleus, when I connected it to web and was able to find Roon Nucleus via my mobile (Samsung Galaxy S10) and logged in.

I realised that it was logged in using previous owner data (for some reason it was remembered by Roon). I logged out and tried to log in using my login data. I am able to find Roon on my mobile and connect. However when I write my login data I can not log in.

There is an information “Network Error, please check the connection”. I tried turning off the router, no success.

Just to add: My previous streamer (Node 2i) worked well with this ethernet connection.

Hi @Bogdan_Piotrowski

Is there any change if you reboot the Nucleus?

If not, please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


Hi, thanks for Your response. I tried rebooting once again, still the same problem. Please find the link below (hope it works, I have never done it before):

My logs are only from today.

Worth adding I unchecked Disable IGMP Proxying

@dylan just tried rebooting everything one more time. Netgear app shows Nucleus is connected and nothing is blocked… Still no connection though when i try to log in, although i am able to see nucleus in my network (eg. copied login files).

Would appreciate Your views on login data…

One more update. I tried to connect through a switch as some posts here suggest and got the same connection error. Is it something wrong with Netgear orbi or my nucleus?

It is a bit frustrating i do not know what to do to make it work…

All my hopes are with Roon support…

Just tried to reset my Nucleus to factory settings. I have the following information. Is something wrong with it (i bought it second hand but this is still on warranty).

Tried one more time and got this (apologies for multiple messages but i am bit frustrated…)

It is working! Seems it just needed reset to factory settings. It is not smooth, but will work on it.

So Nucleus can work with Netgear Orbi:)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.