Network error: Please check your internet connection on my iPad

Hi @Ellen_NG ,

Can you please try to perform an Operating System Reinstall via the ROCK Web Interface? This should not impact your database and it automatically updates RoonServer to the latest version. Let us know if that helps, thank you!

Hi Noris,

Thanks for your help first. Probably it’s better for me to tell you the whole story again.

What kind of hardware I am using for Roon? here is


-iPad Pro

-PC notebook ASUS-UX370UA

Since I haven’t used Roon several months, so when I run Roon Remote apps on my iPad, I found that my account was logged out then I try to login. After clicked login button, an error prompt, “Network error: Please check your internet connection”

I think probably I didn’t run Roon for several months so made the Roon OS or remote outdate.

Then I reset Roon Database and Setting via web UI, too bad, Missing Codecs found on Roon Server Software after Roon Database &Setting rest. OK go to find ffmpeg and install. However, Roon Server Software become version 1.7(build571) after ffmpeg installed.

On the other way, I used PC as Roon core to login Roon and update Roon remote apps. Finally Roon remote apps also updated to versiin 1.8 (build831).

I used remote apps on my iPad to connect ROCK on my NUC, I really don’t know how come Remote Core(Roon Optimized Core Kit)-1.7 (build571) is unable to update. The error prompt is, “There was an error checking for an update". I can using My PC as core to login Roon and update remote apps on my iPad, that means it is not related to my internet connection.

Ok! Operating System is ok no problem at all (version 1.0build227), Roon Database & Setting is reset and remote apps on my iPad also updated to latest version 1.8(build831). Only Remote core got problem and unable to update to version 1.8.

I brought my NUC back to my office and take a look on the update process can be done or not.

Haha… once my NUC connected to my office internect connection, remote app on my iPad to connect ROCK on NUC, Remote Core(Roon Optimized Core Kit) can be update to version 1.8. Finally all are updated to latest version, I was happy to bring my NUC back home.:blush:

Back home, set everything back, use iPad to login, Gosh! GOD play me again. :scream::disappointed::cry::sob:

Error prompt come up again, “Network error: Please check your internet connection” I walked a big circle and back to the starting point…:sob::sob::sob::sob::sob:

I decided to leave it few days for taking a short rest.Then I spent few days to review any tips/hints about “Internet connect” and “Network” on “Roon help” and Community.

I found a article about FAQ: What does DNS mean? How do I change my DNS settings? on help center, follow the instruction to set the DNS to Google DNS

It works, problem solved.

Would you please tell me what’s happening to my DNS? if my DNS got problem, that means I could not get internet connect. In this case, my DNS is blocked? any security issue will be worried if keeping use Google DNS cause Google DNS is a kind of public DNS


All DNS servers will have access from “The Public” many millions of times every second. I doubt Google DNS is any less secure than any other, in fact, with Google’s resources they are probably more secure than most.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.