Network error: Please check your internet connection on my iPad

Roon Core Machine

Operating System: version1.0 (build227) stable
Roon Database & Setting : OK
Roon Server Software: OK

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I’m unable to login in Roon using the iPad, however, I can see Roon Optimized Core kit is in ready on browser.

I didn’t make any new setup, including no new installation of any hardware, such as router or re-installation of ROCK OS, iOS on my iPad. Just didn’t use Roon to play music around several months.

There is no problem on my internet connection, I checked that.

So what kind of network problem? Any suggestion that can be recommended?

I would switch off your Roon equipment then reboot your modem/router and wait for it to fully restart. Then restart your Roon equipment and hopefully all will be okay.

one more screen attached.

When I open the Roon apps on my iPad, this screen showed up first. It show the Core is in ready

It also shows that the core is on server build 806, the latest build is 831 AFAIK. Do you know what build of Roon is on your iPad? I would check that and see if the server builds are the same or if one of them updated and not he other.
Can you get to core with Roon on a PC or Mac and see if needs to be updated?

That means I need to update or re-install Rock OS ?

I reinstalled the Roon remote 1.8 on my iPad but problem still remain

Yes you should do that, so it is running the latest version of the OS and Roon.

May I know what is the latest version for Rock OS?

Read all of this first and then update:

Login to your Rock using your IP address and update from there:-

Roon OS latest as far as I can tell is Version 1.0 (build 227) stable, which is what you have.
It is just Roon program that is out of date from your screen shot.


I have deleted the Roon remote app on my iPad and reinstalled it again, however the apps still is, build806, not 831. the iOS that I am using is 14.8

when I search apple store I see the latest version is 831.

You might want to see if there is an update for it in the apple app store.
I do not have any apple devices so can test to see if it updates or not.

Thank God! Finally can update 1.8(build831) on my iPad.

I think the problem is, “Roon server software” is unable to update to 1.8version.

Have you tried restarting your Roon Server via the UI prior to attempting to update? It would be helpful if you explained what you have already tried to resolve the issue?

Yep, looks like ROCK needs to be updated, also.

tried to restart the UI. still unable to update to the latest version for remote core(Roon Optimized Core Kit) to 1.8

It may be that the update is failing due to a slow broadband connection (or dropping connection) and timing out. Would you be able to use a friend or family members broadband connection? Take your Rock hardware and try to update using a hard wired ethernet connection. I know it’s a pain in the neck but it may get you back up and running. I take it that your hardware is hard wired at the moment?

Best of luck.

I don’t think so, you can see the speed on my internet connection is 362Mbps.

Is there any method to get the updater to uodate manually ?

I see what you mean! I am not aware of any manual method of updating on a NUC other than starting from scratch. The only thing I can suggest is to completely power down your NUC, disconnect all cabling and leave it like that for at least 15 minutes. Reconnect all cabling and power up.

Others may be able to assist if this doesn’t work but I think Support may need to get involved.

Sorry I’ve not been able to help but at least you know that you’ve tried all the basics.

that is strange, your earlier screen shot showed that the ROCK had 1.8 (build 806):

But this one shows 1.7 Build 571, that makes no sense.

This is beyond me, I think its time for @support to get involved here and figure this out.

1 Like

With regards the UI is there an option to update “Roon Server Software” via the dropdown circled where it says “Restart” and have you tried that?

bearFNF has a good point which I missed “that is strange, your earlier screen shot showed that the ROCK had 1.8”.