Network error when I tried to login to my roon account on my roon core

Roon Core Machine

Innous Statement as Roon Server/Core

Networking Gear & Setup Details

T-mobile 5G modem -to-
EdgeRouter -to-
Upton Etheregen -to-
Ansuz PowerSwitch D2 -to-
Innous Statement

Connected Audio Devices

LAN to network

Number of Tracks in Library


Description of Issue

Hi, I’m using my innous statement as my roon core/server. Since this week, I have been having issues logging in onto my roon account on the innous statement. When I connect to my roon app see my innous statement and when I click connect, it’ll ask me to login with my email/password. But when I entered all the info, it’ll often say “Network error: Please check your internet connection”. I had confirmed that I have no network error on anything else and my network is fine. Once in awhile, it’ll let me logged back in but next time I tried to connect again, the same issue will repeat. Not sure what’s wrong lately but can someone help?

Hi @Richard

Just a fellow Roon user here.

Did you purchase the Innuos Statement with Roon pre installed, and from new?

@AMT Yes, and everything was working fine until this week…

Yet another Roon user here but:

Wow, that is quite the network string you have there. Can you use/access the Statement with the Innuos Sense app reliably? Not that really tells us what the issue is with Roon but it is a data point.
Is the firmware on all those devices up to date? Is Roon up to date?
When was the last time you cleared cache and rebooted the network and devices?

Is there a pattern or something else that you are doing or that happens in the background around the same time that you loose connection?

As a test, do you have any issue running a core on one of your PCs/MACs (whichever you have)?

I have seen this issue with others when they have too many switches and hops or managed “smart” switches that either can’t keep up with Roon or can’t get Roon a consistent IP address when it needs it.
“Smart” switches are not perfect and can be an issue, Managed switches are also not perfect and need proper set-up and “management” :stuck_out_tongue_closed_eyes:.

My suggestion would be to simplify the network for testing to see if any of the switches (Uptone or Ansuz) is an issue with Roon. Yes, I know you say, “no network error on anything”, except the Roon Core which is a bandwidth hog… so, just for testing, it would be nice to know if they are issues.

Also, another suggestion would be to swing over to Innuos and ask them for support.
Or, once you do some testing maybe one of the switches needs some support from that manufacturer?


Hi @Richard,

Diagnostics appear to indicate that you might have resolved this issue. Are you still experiencing a login issue?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.