Network folder on (MacOS) remote? [Answered]

No answer after three days, so I thought I’d try again. I run Roon ROCK and usually control it from Remote running on my MacBook Pro. This is my main working computer, and typically I download audio files onto the MacBook Pro before transferring them to a USB drive attached to the ROCK.

I would like to set up Roon to access a directory on my MacBook Pro so that I can check out music on the laptop before integrating it into the main Roon library. I think, but I’m not sure, that this means that my MacBook Pro will become an smb server. In any case, I just need some specific instructions. Can someone help?


I don’t think I’ve ever posted a question on the Roon forums and didn’t get a single response, until this one. So I thought I’d try one more. I don’t know if it’s appropriate–please tell me if it’s not–but I’m going to ping @support in hopes that it will get noticed.

The laptop I use as remote is, obviously on the same network as the core. I usually download or rip files to the laptop before transferring them to core storage, and before I transfer them I like to make sure everything (including metadata) is in order. This would be greatly facilitated if I could specify a folder on my laptop as a source of Roon music files–that is, make it so that Roon core can “see” a file on my laptop’s storage. Is this possible? How should it be done?


Hi @Jim_Austin ----- On the remote computer (i.e MacBook Pro) you are going to want to go “system preferences” and then “sharing”. Check “file share” and then in the “shared folders” window you will want to use the “plus” sign to select the folder you want ROCK to see. In the “users” window to the right of the “shared folders” you will set the permissions for that shared folder (i.e read only, write only, etc).

Once you have the above setup you will click the “options” button and and make sure “share files and folders using SMB” is checked. “share files and folders using AFP” should be left unchecked. Now launch Roon and in the “storage” tab you are going to add it as “network share” (example below):

FYI: In the "password field you will use the password associated with the MBP.


1 Like

@Eric, Brilliant, looks straightforward. Thanks much.


@Eric , This didn’t work, unfortunately. To make sure I had the credentials right, I connected via smb from my son’s MacBook Pro; it worked fine. Then, since my son has RoonServer set up on that computer, he tried setting up the smb connection from Roon. In both cases, the message said the connection was “unauthorized.”


Hey, can someone else give this a try? I’m sure I’m not the only one out there with this hardware (or need). To sum up: I’m trying to establish an smb connection from Roon ROCK to a drive on my MacBook on the local network Pro (which, fwiw, runs Roon Remote). I find that I am able to establish an smb connection from a different computer to this same MacBook Pro, but the instructions @Eric offered above don’t work for me, from Roon. When I try to connect I get “unauthorized.”

Maybe someone else with similar hardware can give this a shot? Thanks in advance.


I see a couple of possible problems. First do not use the IP address of the computer use the network name. The IP address is most likely assigned and can change.

I have a very similar set of hardware to test with, NUC running ROCK and Macs all over the place.

OH you did get the username and password correct>???


OK I found that I had to tick the Box in the Windows file sharing to make it work :slight_smile:


Bob, thanks VERY much for taking the time to check this out for me. Your advice about the IP address makes sense. As for the rest, I definitely ticked that box, and in fact I got it (the smb share) to work from another Mac. But with exactly the same info, it doesn’t work from the ROCK.


Bob–actually, I mis-wrote. In fact I do NOT have the Windows file sharing box checked. You might be right that that’s the problem. Unfortunately, I can’t seem to check it. It’s grayed out. Not sure why:

OK that is just weird… Are you on Sierra or High Sierra? If on HS that last update had enterprise updates that ?might? Effect this.

You could try a log off and log back in. I also assume that your account is admin.

In the little test I did Roon would not connect until I had checked the Windows SMB thing.

I did not google around for any stuff about that checkbox and I am off to a family gathering so I do not have time to check right now.

Get that sharing working and i think you are good to go.


PS I do the same thing. Acquire, backup and copy up music that you do. In the past I have shared a music folder from the Mac but not in a long while. I have migrated to SSD based storage directly on the Music Server…

Bob, thanks again. FYI, I’m running Sierra still; haven’t pulled the trigger on the upgrade. I am using an admin account. I’ll scour the web for a solution. Happy Holidays.

Done! The problem was a strange one as you might expect. My iCloud password was the same as my password for the computer. I changed that–made them different–and then I could select “Windows Sharing” and everything worked.

Found this online of course; would never have thought of it myself.

Thanks for the help.


Well I am so glad it was “simple”. My Apple ID password is pretty long and I have the two factor stuff turned on and I have always kept it separate!.

I am glad it is working for you.

@support, take note: One of those small details that don’t make sense but are crucial for making things work. It is necessary to check the Windows Sharing box in order for this to work. And as I discovered, you cannot check the Windows Sharing box if your Apple ID password matches your computer account/admin password.

Thanks for the help.


1 Like