Network path - How to write it

Roon Core Machine

2019 iMac, Sonoma 14.0, 3GHz Intel Core i5, 48GB RAM

Networking Gear & Setup Details

WiFi connection

Connected Audio Devices

Rpi4 (Ropieee) as end-point, connected via Ethernet cable

Number of Tracks in Library


Description of Issue

Could you please tell me how to write the network path below in the add “network share” section of the “backup” window of Roon?

I am trying to set up a Roon ROCK NUC as new core, and need it to point to this back up location, so that I can restore the latest backup from the iMac core to the (new) ROCK core.

This path is working fine today.

However, I do not know how to write it.

I tried “smb:// - TE iMac/Théodore/Théodore - Personnel/HiFi/RoonBackups” but the system does not accept it.

Alternatively, it would be great if Roon offered a way to just browse the network locations, rather than have to write the path. Is that at all possible?

Have you shared it within MacOs as users directories are not shared by default.

You could try just this way round \\ipaddress\etc\etc this how I mount my NAS to backup to.

Why give yourself such grief? Create a top level directory and use that.

1 Like

Well, I did activate “Share” in folder information, but no cigar.

I’m not sure what “create a top level directory” means. Roon asks you to set the “shared network” whatever that is…

You entering your username and password?

I enter 3 things that Roon asks for to find a back up location:

The target file on the shared network (which is shown above)
My username and password for the server on which the target file is.
I get “unauthorized access” but I don’t know why.

When I access the same file from another machine in the network, with the exact same credentials, it shows up just fine.

^ There is an extra slash after ‘123’ make sure that isn’t the case when trying to connect. And, you don’t need to write ‘smb’.

Make your life a little easier and not have it hidden in so many folder directories. Make a new folder under your username. Example:


1 Like

In any case let me thank you both @Simon_Arnold3 and @ged_hickman1 for your interest in my issue and for trying to help!

And you have shared it via file sharing in system settings as a SMB share, then choose your user and add password. Works fine for me just set up my Desktop folder.

You just enter \\ipaddress\sharedfoldername in Roon doesn’t need full unc path just ip and the shared folder name.

That’s exactly what I do. And it does not work. I keep getting an “Unauthorized” message.

At the same time I can access the folder just fine from any other (Mac) computer on the network.

It is only from the NUC running ROCK that I can’t access that folder to designate it as backup.

You sure you made it a windows share? it has to smb not AFP.
Screenshot 2023-11-04 at 16.38.30

Works fine for me so your missing a step somewhere.

1 Like

OK, looking at the screenshot you kindly shared, I realize that I need to add myself to the users (with the + button). I think this is what I was missing. Will try it right away.

No cigar. But thank you.

Yes. I have SMB sharing “on”.

You are right that I must be missing something. But I can’t figure out what it is.

The windows bit is needed as I posted. You need to set that under SMB. It doesn’t work for Roon without that it seems.

I like to avoid spaces in paths.

Shorten your path to just the ip and the shared folder you don’t need the full path and try that.

1 Like

Thank you all @Robem, @Simon_Arnold3, @ged_hickman1 for your advice! After using the “ipaddres” (thank you @Simon_Arnold3 for the very helpful screen capture), and shortening the path to only the folder (even though this is contrary to Roon’s instructions page), and some experimentation with the username it worked.

The same procedure with the server name instead of the ipaddress does not work. Again, Roon’s instructions appear to be incorrect.

Still seems like a random result, and it took me about 6 hours of experimenting to get there. I wish Roon would allow to simply “Browse” the network, just like the interface of a Mac.

Thank you all again, and happy listening!


I suspect a network issue lies at the root of your difficulties - the Roon Help instructions are in fact correct.