New albums not appearing in Roon [Resolved]

I am a new user of Roon and set everything up OK. Roon seems to have detected everything in my library initially. I am now adding some new albums but Roon does not add them to its library. I have tried restarting the Roon core and forcing a rescan.

Roon core is running on Mac Mini and music library is on a NAS drive. The files are in FLAC and M4A format and play OK outside of Roon. Permissions don’t seem to be a problem as the user (“roon”) has full read/write access.

Hi @wilro15 ----- Thank you for the report and sharing your feedback with us, both are appreciated!

Moving forward, can you please provide the following information:

  • Have you confirmed that none of the content has landed in “Skipped Files”?
    (Settings - > Library - > Skipped Files)

  • I see you’ve tried power cycling your Roon core (:thumbsup:), have you tried power cycling the NAS as well?

  • Can you pease provide the model/specs of the Mac Mini hosting your core.

  • Please verify the model NAS you are using and how big of collection it is housing based on number of tracks.


Roon Knowledge Base: Some Of My Files Aren’t Showing Up In Roon

Roon Knowledge Base: Skipped Files

Hi Eric. Thanks for getting back to me.

I figured out the problem. Roon connects to the NAS using an account called “roon” which has read/write access (according to Synology DSM). When I copied a new album onto the NAS I connected with a different account (also has read/write access).

I noticed that Roon could not “see” the new album when I tried to map another drive to Roon. So I removed the shares and re-added as the same user. Now it works!

Must be something weird going on with permissions - even though both accounts have full access.

1 Like