New install, No audio, HTPC to AVR via HDMI (Windows 10)

I’ve just installed Roon and have no audio, even though progress bar shows song is “playing”. Audio playback using VLC is fine so I know it works. HTPC is connected to a Panasonic SC-65 Pioneer Elite SC-65

via HDMI. I’m running Windows 10 Home 64-bit. I made sure that there is noting else playing that could interfere. Here’s a screenshot to show the errors that I’m seeing;

I’m getting disapproving looks from my wife, something to do with Christmas :wink: so this will have to be quick.

I assume you have selected the right zone for Roon to stream to, it’s worth double checking.
Can you post a screen shot of the signal chain (click on the glowing dot, just to the right of what’s playing now).
The we can see what Roon is attempting to do.

Totally unrelated, but, I suggest getting rid of ASIO 4 all. Causes all sorts of issues and it is probably not doing what you think it is to your audio stream.


Whoa…you guys shouldn’t be doing this on Christmas…I definitely don’t want to be the cause of any “domestic strife”. at best, I was expecting an answer by the weekend.

I deleted ASIO as suggested by Daniel, which promptly made no playback possible at all. So, a bit more troubleshooting and I decide to delete my Win10 audio drivers completely. Then, reinstalled the Realtek HD audio drivers from scratch. Everything works now so I can really put it through its paces. Here’s my signal path, Carl:

Thanks for your help guys and I certainly hope you have/had a Merry Christmas!

Hi again,

Great you are up and running now, though routing via the OS mixer can do horrible things to the sound.

To avoid this you should be able to select exclusive mode in Roon. It’s something to play with when you have a few minutes… then you’ll have a bit perfect purple star all the way though.

When I put it in exclusive mode, my signal chain changes correctly and the song “plays”:

However, no sound. When I turn off exclusive, I get sound. I tried toggling event driven mode on and off, but didn’t make a difference. Suggestions?

One thing to check for is that no other applications are your HTPC are attempting to use the soundbar whilst your using Roon.

However, I see the Panasonic SC-65 soundbar is connected via HDMI which may be why exclusive mode is not working with Roon as it typically connects to USB or Networked devices.

I’ll drop a flag here for @Mike to pick up and confirm.

I looked at the manual for that soundbar and there is no HDMI connections. TV is connected via Toslink. u7nless I’m looking at the wrong device. Panasonic SC-HBT65

@Holland_Wood can you verify how you have the PC hooked up to the soundbar? Is it HDMI to the TV and then optical from the TV out to the soundbar? Or is it optical straight to the soundbar?

TYPO on my part, gents, sorry. My AVR is a Pioneer Elite SC-65. It’s connected via HDMI and seems to work fine in non-exclusive mode. Just toggling exclusive on/off (playing the same track, though it pauses) and I get no sound/sound.

Hmm. I would suggest that you plug the pc in via toslink and see if that makes a difference.

Toslink not an option on my HTPC (which is more of a NUC). I’ll take a close look for other software somehow interfering. One thing that’s weird is that it shows a JRiver ASIO driver as on the the output options in Roon. I uninstalled JRMC months ago…seems there’s remnants remaining that I have to dig out. Otherwise, I’ll have to try USB to my AVR in order to get bit perfect.

What do your volume settings look like? I would check in Roon, and in the Windows mixer for your RealTek, confirm that neither is turned down or muted.

Also, I assume your sound card has some other outputs besides HDMI? Do those outputs work in exclusive mode, or do they have the same issue as the HDMI output?