New ISP issues with ARC set up

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have just changed ISP and I may not be able to use ARC, on checking I am getting the following:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nAction Failed\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Any advice is welcome

Hi @Glimmer,

Could you please answer below questions?

Who is your internet service provider?

Please list the make and model of your modem and router?

Do you have any additional network hardware, like additional routers or managed switches?

Does your network have any VPNs, proxy servers, or enterprise-grade security?

What machine are you using as a Roon Core, and how is it connected to the internet?

Kind regards,


Hi many thanks for your response

Lightspeed Broadband FTTP

Nokia 6

No additional routers

Tailscale (but not on the NUC)

Intel NUC in a fanless case with an Ethernet connection to the Nokia

I have set up a static IP address, enabled port forwarding and generally been really positive!

Someone has the same error also with a Nokia router, but as of yet unresolved:

As was suggested in this thread, this looks like UPnP might not be working:
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”

Sounds like you are comfortable with setting up port forwarding manually, could you try?

Hi, thanks for the response, I had to manually set up port forwarding, but it still failed to advance much. I am quite relaxed about it as I had heard about potential issues with the Nokia.

On the positive side, Roon is working incredibly well and early access has been a delight.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.