New MacBook does not find Roon Core

Roon Core Machine

iMac 27 late 2014, Catalina 10.15.7, 4GHz Quad-Core Intel Core i7, 32GB
New Macbook Pro 16" 2021, Monterey 12.1, Apple M1 Max, 64GB

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have bought a new MacBook Pro and I set it up by transferring all files from my iMac. When I tried to connect the MBP to Roon Core, nothing happens. I have tried to enter the iMac network name and its IP address, without any response. I then deleted Roon from the MBP and reinstalled it. It still will not find Roon Core. I then removed all files I could find, with the name Roon in it and reinstalled again. Still nothing happens.

Can you please give me a point by point list (tea spoon by tea spoon …) on what I have to do, to be able access the Roon Core from my new MBP.

In case you have an iPhone (or iPad / Android phone or tablet) with Roon remote installed - could this find the core?

I have both an iPhone and an older MacBook Pro connected to the Roon Core. Setting those up went very smoothly.

As you happen to know IP address and name of the core could you start a ‘terminal’ on the new MBP and ping towards this? Beyond this basic connectivity test: any 3rd party security software installed on the MBP?

Xnip2022-01-24_21-15-22

He he, you may be above my computer grade already. I am not knowledgable here. However, setting up the MBP with everything from the iMac, over the network, went just fine. And the new MBP is connected to exactly the same network as the old MBP and iPhone, so, as far as I can tell, there should be no problem with connectivity.

By the way, there is no security software beyond any standard Apple software.

Ok, sry. Let’s then say all are on the same network connected to the same internet router. Can you confirm basic internet access (browsing) works fine with the new MBP?

Yes, everything works just fine, with everything but Roon.

Brute force suggestion: Power cycle all parties involved.

Internet router, iMac, new MBP

Idea: Sometimes a router behaves strangely when uptime is way too high. This can result in all types of network issues. Shut down every computer gracefully (don’t just pull the plug) and allow the router like 2 minutes without power before reconnecting.

1 Like

OK, shut down in progress …

I shot down everything, iMac, 2x MacBook Pro and the router. Everything is now booted up again and nothing has changed. My MacBook does not fine my Roon Core.

From a Finder window on new Macbook is the iMac visible in the sidebar? If not is is visible when you select the Network icon in the sidebar?
My Roon Core is named ROONSERVER on the network and is visible, were it not clicking the Network icon would reveal it.

The iMac is visible, but no Roonserver …

However, on my old MacBook, the iMac is not visible and that is working …

Just confirming that the Roon Core is running on the iMac.

There could be an IP conflict happening here.
Roon core should have a static IP and transfer of settings from the iMac to the MBP (if done through migration assistant) could change the system settings so the MBP has the same IP as the iMac.
In System settings - Network - Ethernet, check that your IP address (192… or 10… or similar) is different across the two devices.

You CANNOT just import a Time Machine to restore a Roon core - if thats what you have done then you need to completely remove RoonServer form the new Mac and install from scratch - removing the ~Library roon folders too. then restore a backup from the old core.

We strongly recommend against using Time Machine, Crashplan, Backblaze, or other backup applications to backup your “live” Roon database. If you would like to use any of these applications to back up Roon, set up a Scheduled Backup and tell your backup program to backup the RoonBackups folder.

1 Like

I realize I should not have gone the easy way … it was very convenient to get all my software across.
However, when I enter the Library, I cannot find the RoonServer. Is it hidden under any other name/folder?

Hi Eldar. Sorry to hear you’re experiencing these issues. If you haven’t yet, please try the following steps on your new MacBook Pro.

  1. In your Applications folder, move the Roon app to the trash

  2. Click anywhere on your desktop and on the menu bar it should say Finder

  3. On your keyboard, hold down the option key and then on the menu bar click Go

  4. Click on where it says Library

  5. In the Library window that opens select the Roon folder and RAATServer folder - move both folders to the trash

  6. In the Library window again, open the Caches folder and inside it, select the com.roonlabs.raat folder then move it to the trash

  7. Go back to the Library window again, open the Saved Application State folder and inside it, select the com.roon.Roon.savedState folder then move it to the trash

  8. Restart your MacBook Pro, download Roon for macOS and install it into the Applications folder

  9. For good measure, restart your iMac where your Roon core resides and then try launching Roon on your MacBook Pro to see if you are able to connect to your Roon core

I hope this was helpful but please let me know how it goes. Thank you!

1 Like

Excellent, worked like a dream. Thank you!

1 Like