New MacBook M1 Air Not Detected

Sonic Transporter i5 Version 2.8

Roon Server Version: 1.7 (build 667) stable

Arris Router

Just got a new MacBook M1 and Roon is not finding it as an output device. My iPhone being found. Old MacBook updated to Big Sur also can’t be found. Wifi.
Firewall is off on both devices. Any advice please?

Hi @Stuart_Grossman,

Did you use Time Machine or anything like that to install Roon on the new device? Or did you install it fresh from our website?

Great point. Time Machine. Should I uninstall and re-install from site? Also did indeed get things running on the old mac running Big Sur…my mistake.

Hi @Stuart_Grossman,

Have you followed our Migration Knowledge Base Article to transfer the Roon database to the SonicTransporter?

If so, yes, a reinstall of Roon can help in this case, you can use the below instructions to do so:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (on the Mac)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to SonicTransporter Core
  • Let us know if issue is resolved

Update…now it appears the new Mac is being recognized but when I try to play an album Roon rapidly scrolls thru all the cuts of the album without playing any of them. This appears to be happening only on the new Mac. Tidal plays fine. Also to be clear, the SonicTransporter has always been my Core. I assume I should still follow the protocol you laid out…yes?

Hi @Stuart_Grossman,

Yes, please try the above instructions to reinstall Roon on your Mac, do let us know if it helps!

I did not migrate the dB to the SonicTransporter because from day one the SonicTransporter has been my core and I’m continuing to use it as my core. Roon was pre-installed on it.

I did the db backup to a NAS. Uninstalled and reinstalled the Roon app.

The new MacBook still is not being discovered.

The old MacBook running Big Sur was discovered after a bit of latency and is fine.

Hi @Stuart_Grossman,

Can I please ask that you use these instructions to access the logs from your new Macbook (not the Core) and send me a log set?

Logs from new Mac.

1 Like

Hi again. Did you get the files and are they ok? Is my MacBook ever going to be an endpoint for Roon? I can deal with any answer but the suspense is killing me. :slight_smile:

Hi @Stuart_Grossman,

Thanks for sending those logs over and for your patience while we had a chance to review.

Looking over your logs, I’m noticing RAATServer failing to properly, I suggest we try a RAATServer refresh to see if it will help with this issue.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

If you perform the above instructions and the issue is still not resolved, please reproduce the issue and send a set of logs from your RAATServer folder. Thanks!

Hi again. I did as suggested with the RAATServer folder. Problem not resolved. The MacBook is still not being detected as a Roon zone. Here are the logs from the raatserver folder.

Greetings. Have you successfully received the RAATServer logs? What’s next?

1 Like

Hi @Stuart_Grossman,

Thanks for sending the log file. I am not seeing any devices appear in the RAATServer log, including the Mac’s own System Output zone, this is strange.

Are you by any chance using any Antivirus or Firewall tools on that Mac? Is there any change in behavior if you temporarily disable it if so?

I would also check to make sure Roon is added as an exception to your Mac firewall by using these instructions.

If that does not help, my next suggestion would be to try to host the Roon Core on the Mac and see if that changes anything (this test should give us some more data points):

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Mac native firewall not on and I just uninstalled CleanMyMac. Problem still there.

I’ll try switching the core to this mac that is not being recognized shortly…thx

1 Like

DON’T HATE ME! Your instructions above had me exploring the settings prior to switching Cores. I found that I failed to enable the new Mac from the SonicTransporter core.

Operator error, ya?

Thanks for hanging in there with me and hopefully this little episode is something that you can add to your knowledge base/troubleshooting (if it’s not already there!).

Stu Grossman

1 Like

Hey @Stuart_Grossman,

No worries, glad to hear you were able to find the issue.
Happy holidays!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.