New NUC install--updating BIOS, no boot order choice

I am trying to configure a NUC8i7BEH. I think I successfully updated the BIOS and I am now trying to configure it, but I can’t see the m.2 in the boot priority.

I am at the screen in the BIOS UI where I can choose between UEFI and Legacy boot priority. I unchecked UEFI and checked Legacy Boot. The next step in the instructions is to select my SSD as first in the boot order. I don’t see how to do this.

In the Legacy Boot Priority box, there is a line “Boot Drive Order No Boot Drive”. my m.2 ssd does not appear (nor anything else).

i think the m.2 is installed properly because i see it under the SATA tab in the BIOS UI.

any ideas? thank you!

Maybe…Go to Advanced. Under Boot Configuration - Boot Devices, Turn on USB Boot, Disable Network Boot, if there is an m.2 boot device then turn that on.

After you have updated the BIOS. Turn the NUC off. (Just press the power down and it will power down.

Hold down F2 as you turn on the NUC.

Press F9 to set BIOS to factory defaults.

Select the Legacy Tab.

Check that Legacy Boot is enabled.

Underneath the box, click the blue “Advanced” box

A screen titled Intel Visual BIOS will come up and underneath that are a row of boxes.

Select Devices

Then select the PCI tab

Check that the M.2 Slot is checked (it may be turned off).

At the bottom of the screen hit F10 to save everything.

Hold down the F2 key as the NUC reboots. It will bring up the Visual BIOS screen again.

Click on the Legacy Tab. The M.2 drive should now be listed

Drag the M.2 SSD drive to the first in order.

Make sure Enable USB Boot is still enabled.

Select F10 to save and exit.

When the NUC powers up it may try to boot from the network. If you are getting a message like that just press the power button to turn off the NUC.

Now you can proceed to Step 3 of the ROCK installation instructions.


Yes, that is where it is. Trying to do it by memory. :frowning:


As long as there’s no partition on your m.2 you won’t get it as a boot option.
So just install an OS and you’ll also get it as a boot option :wink:

Hope this helps.

1 Like

thank you! i think this worked. i would never have figured this out.

my new problem is trying to update the codecs. working on trying to get files out of a .xz.

Great! We’re glad to help you along the way.
Winzip works well on a Windows machine. Note the file inside the .xz file is also zipped. You will be looking for a file that is only ~72 MB.

i used 7-zip to successfully extract the ffmpeg file. but now i can’t get to the Roon OS’s /Data directory. i tried typing \\ROCK\ in file explorer (i am using windows 10 enterprise). i originally got a creditial error. i rebooted and now i get a network error, saying windows cannot access \\ROCK\ and to check the spelling of the name.

is there another way i can get the ffmpeg file into the proper directory? thanks!

Have you tried typing in the IP address of your ROCK box?
Sorry. Are you trying to get to that folder?
Can you see it under Network?

yes, that brought me to the webpage with the buttons for missing codecs, reinstalling the OS etc.

oh, when i look under “network” in file explorer, i see my firestick and printer but i do not see the NUC. i thought i should see it.

You might need to turn on Network Discovery.
Settings>Network>Sharing Options>Turn on Network Discovery

Another way to do it is to hold click on “This PC” and a box will come up with Map Network Drive.
It will suggest a drive letter and below that is a folder box.
In that box type in the ip address of your ROCK. It will be something like \\\data
Map that drive. Then you can access the Codecs folder or any other folder like Internal Storage.

network discovery was turned on. also, i enabled something about finding smb shares. i’m not sure why i am having so much trouble.

Windows has its fits. And it will always do that when you are in a hurry.
You may need to reboot everything to get network discovery looking for the new device. But I know this sometimes disappears for no good reason. That’s why I’ve mapped the drive. Dependable.

i tried mapping the drive and it didn’t work, and i think i know the problem (sort of). i am using a work computer, and i think there are security protocols in place that aren’t allowing me to map the drive, or otherwise connect to it. next step is to email my IT guy.

thank you for your help! i will report back when i know more. and if you have another idea, let me know!

OK. I’m out of ideas anyway. Good luck.

Enterprise edition was a red flag. I can’t do anything like this with my work laptop.

I used my wife’s mac and it took about 2 minutes to transfer the ffmpeg file to the codec folder on the NUC. i’m still not sure why i had so many problems with windows, but I do think it is because of the security protocols on the enterprise version I am running.


I am now using ROCK on my NUC! my only endpoint is my laptop.

i ordered two Rpi 4s, a DAC HAT and a digi HAT from hifiberry. when those come i’ll be trying to set them up with Ropieee and then connect to existing audio gear.

Be prepared for more questions when that happens :).

Thank you everyone very much for all your help!

1 Like