New Roon install - "LoadLibrary failed with error 87: The paramater is incorrect"

Core Machine (Operating system/System info/Roon build number)

Dell XPS 8940
Intel® Core™ i9-10900 CPU @ 2.80GHz 2.81 GHz
RAM 64.0 GB

Windows 10 Home, 20H2
OS build 19042.685
Windows Feature Experience Pack 120.2212.551.0

Description Of Issue

I’m trying to install Roon on a new computer, and will move the core/database once that’s done.

After downloading Roon from the website, it will not open. I keep getting this message: “LoadLibary failed with error 87: The parameter is incorrect”

I’ve updated Windows and the drivers. Every other program I tried has worked with no problems. Roon seems to be only one having an issue.

Any fixes for this? The other mentions of this in the Forum don’t seem to have a clear solution.

Thanks in advance,

Driver updates seem to have taken care of the “LoadLibrary failed with error 87” issue.

Now, however, I’m getting a different error message and Roon still won’t open.

 Roon could not find WGL functions required to initialize OpenGL.

 It is likely the proper drivers for your display hardware are not installed.

 Up-to-date drivers should be available from the website of your computer or GPU manufacturer.

The Dell customer service rep who took over my computer checked all the drivers and messed around with it for a while, but was not able to get rid of that error message. We went through this page,

The Open GL Extensions viewer says the Intel UHD Graphics 630 supports GL 4.6.

I don’t know what to try next. Running RoonServer instead of the full Roon is not what I was going for here.

Try installing the graphics drivers from the Intel site not dell or windows update.
You can use this utility to check

Thanks. That site tells me my drivers are up date.

The Display Drivers listed in Device Manager are:

AMD Radeon RX 5700 XT
Intel UHD Graphics 630

Both are up to date.

Maybe try assigning roon to each graphics in turn to see if that works

1 Like

You, sir, are a genius. Assigning it to Intel UHD Graphics 630 did the trick. Thank you very very much!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.