New Roon Nucleus+ - "something not right"

Hi everyone.

Just got a new Nucleus+, and I’m having a migration issue that I can’t figure out.

  • Nucleus+ only connected to a hard wire Ethernet and power.
  • Created a brand new backup from my old Roon instance.


  1. Restore backup (message: “restoring backup”)
  2. Relaunch (button)
  3. Choose your Roon core
    FIRST ISSUE (which has happened three times): “connection failed” message, so greyed out “connect” button
    SOLVE: relaunching the Roon Windows client I’m using (not the Nucleus) connects
  4. Roon “login or sign up” screen - enter username & password, press “login” button
  5. Roon symbol animation, later followed by “The new version of Roon you installed requires a database update.”
    PRIMARY PROBLEM: After a while, a short “Waiting for your Roon Core” message (with a circular timer animation), followed by “Uh oh, something’s not right.”
    I’ve tried a few times:
    a) once there was a license screen behind that message (I believe to deactivate my old core)
    b) a few times there’s the Roon logo animation or “The new version of Roon you installed…” message

Only way to connect after that is to restart the Nucleus+, which brings me back to the Roon “login or sign up” page.

I’ve tried swapping Ethernet cables with no effect.

Idea #1: maybe a license issue (I remember having that problem last time I moved my core and support had to solve it with their back end system)?

Idea #2: I have a large collection, and a 16GB RAM module waiting to be installed after I knew the Nucleus+ itself was working fine. Is it possible it’s running out of RAM and I should just go put in the new module?

Something else?

Thanks for the help,


how large is the collection and where is it stored?

go to the nucleus web GUI and reset the database to ensure everything is as new and also do a reinstall to get the latest build

then restore the backup once you have connected from the windows roon interface

you might have to deauthorise the windows core you were using

screen shot the GUI here too

Did you update your Nucleus+ first before your step 1? That is an essential step for every brand-new Nucleus/Nucleus+

Use the Web Administration page to do this.

@Geoff_Coupe - I did indeed update it first thing, thanks for checking.
@wizardofoz - here’s the screenshot:

All looks normal & right to me. I believe those are all the latest builds.

Collection is on a NAS. It’s large (in other threads, I saw it called in the 1% of users - thus the Nuclues+ not the regular Nucleus). I can’t give specifics right now because the machine the current core is on has been taken apart to be upgraded for its new use. I can always put it back together if need be.

FWIW, I’ve done the “restore backup” step both from a connected USB stick as well as the NAS (I tried both in case it was the issue). So the Nucleus+ is connecting to the NAS no problem.

Thanks for the help,


wait for the post to get into @supports queue

OK. @support - looks like this one is technical enough that this great community can’t really help.

Is the fact that it goes into a “waiting for your Roon core” state right before the “uh oh” message indicative of a crash or some other behavior? I had my two ideas listed above - any suggestions, or maybe it’s something else?

I’d really like to get my new Nucleus+ up and running.



Hi Vog,

In following the thread, I’m a bit confused at what has been resolved and what has not. Just to be clear, the issue occurs when restoring a previous backup. (Fellow user here).

Hi @Rugby.

Thanks for trying to help out. Nothing has been resolved from the initial post. I have a new Nucleus+ that at first install (which is a transfer from an existing Roon core - i.e., restoring a backup) is bombing out after the username/password screen step.

Specifically, after entering the username/password, I get the Roon symbol animation, later followed by “The new version of Roon you installed requires a database update.” After a while, a “Waiting for your Roon Core” message (with a circular timer animation) shows up for a very short period of time, followed by “Uh oh, something’s not right.”



Found the time this morning and went in and swapped the RAM module to 16GB just in case that was the problem.


For anyone reading this in the future and looking for help: if you have a large collection and run into the “something not right” message during migration to a Nucleus, it very well could be not enough RAM. Apparently, if Roon runs out of RAM it’ll simply crash out after you enter the username & password step.

The solve: add more RAM.

Thanks to everyone who tried to help,



This in fact has been confirmed by Roon staff on several occasions. Glad you were able to get your Core back online!

1 Like

Hi @Vog,

Sorry for the delay in getting to your report. I’m very happy to see that you found the culprit! If, however, you experience other issues please let us know right away. We’re happy to help! :pray:t2:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.