New Roon set-up on Synology DS918+, All great apart from Live Radio not working

Roon Core Machine

Synology DS918+
DSM 7.01
4 x 2TB spinning disks configured as 2 RAID 1 volumes
Volume 1 has 2 x 500gb SSD cache (a mirrored pair)
Roon & its database are in its own directory on volume 1
My music library is also on volume 1
Volume 2 is used for all non-music data storage and backups of other computers

Networking Gear & Setup Details

The DS918+ is connected by Cat6 to a 24 port unmanaged D-Link switch
Wireless network is an Orbi, connected to the D-Link switch with 2 satellites round the house. It gives a very strong, reliable and fast service across the house.
The Orbi is connected to fibre internet - good capacity, no performance issues.

Connected Audio Devices

Wifi link to Naim Muso, Naim Muso QB, Apple iMac
Control of Roon is via app on an iPad or iMac both connected wifi to the Orbi
Marantz AV receiver, connected to D-link switch with cat 6

Number of Tracks in Library

18,000 tracks in library
under 1TB of music on volume 1 of DS918+

Description of Issue


I am brand new to Roon, just installed it on my NAS. I have a low level of skill with this sort of technology. I am a complete novice with Linux.

The install was easy and most things ran immediately. Performance for playing digital files is great - even 192/24. However, I cannot get Live Radio to play. Every radio station I’ve tried gets the message:

Playback was interrupted because a track failed to load

This happens on AAC streams and MP3 streams regardless of bitrate.

After reading the all the support topics I could find, just in case, I downloaded the recommended FFMPEG codec and put it into the RoonOnNas/bin folder then restarted Roon. This has made no difference.

Here is a paste from the log, and its the same messages every time I try no matter which radio station or whether its MP3 or AAC:

2/03 14:44:33 Trace: [ Mac] [HighQuality, 16/44 FLAC => 16/44] [100% buf] [STOPPED @ 0:00] Newstalk ZB Auckland
12/03 14:44:34 Debug: [easyhttp] [241] POST to returned after 937 ms, status code: 200
12/03 14:44:34 Debug: [easyhttp] [242] POST to returned after 946 ms, status code: 200
12/03 14:44:35 Trace: Got ICY Stream Title [Newstalk ZB - New Zealands number 1 Talk Station]
12/03 14:44:35 Warn: [streammediafile] error reading stream: Unable to read data from the transport connection: Software caused connection abort.
12/03 14:44:35 Warn: [zoneplayer] Remote Load Failure While Opening Sound: icy:// Icy: Failed to read first sample
12/03 14:44:35 Info: [ Mac] [zoneplayer]     Open Result (Playing):Result[Status=MediaTooSlow]
12/03 14:44:35 Debug: [easyhttp] [243] POST to returned after 934 ms, status code: 400
12/03 14:44:35 Debug: [easyhttp] [244] POST to returned after 931 ms, status code: 400
12/03 14:44:44 Info: [stats] 23047mb Virtual, 1126mb Physical, 205mb Managed, 312 Handles, 76 Threads

I’m not sure what to try next. Please can anyone suggest what I should try next?


Hi @Ian_England1 and welcome to the forum.

This doesn’t read like you uncompressed the download (probably twice) and put the one file named FFMPEG from it into the RoonOnNas/bin folder.

Points to the same root cause: Missing CODEC.

Thanks for such a quick reply.

Ah, ha - I was just checking that I had done as you say… and I noticed I’ve used the ARM 64 FFMPEG download and I think the recommendation was AMD64. Let me try that again!

ARM builds surely won’t work. :wink:

That fixed it! Thank you for making me look more closely!

1 Like

Glad to see that now it is all working for you. :slightly_smiling_face:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.