New Roon User - Adding Network Share Issue


I’ve read a few of the posts and have tried the online resources but still keep getting the same error.

I initially used my Windows PC as the Roon core and created a backup saved on the D:\ partition of my hard disk in a folder called Roon Backup (filepath: D:\Roon Backup\RoonBackups). I have right clicked the folder and clicked on Share folder which has the follwoing networkpath - \DESKTOP-8XXX0VN\RoonBackups

I have set up a new Intel NUC to use as a Roon Core and have successfully installed ROCK and codecs onto this.

Follwoing the instruction I want to restore the backup onto the new NUC Core. When opening Roon I can select the new Core (Roon Optimized Core Kit) and click connect. Rather then type in my log in details I click on the Restore a Backup at the bottom of the screen.

On the pop up window, there are no drives showing other than DropBox, so I click the “+ Add Network Share” button. On the new pop-up I have tried both filepaths above, but always get a pink box with the following error message “There was an unexpected error: UnexpectedError”

When I use this filepath \DESKTOP-8XXX0VN\RoonBackups I get a Roon icon appear and it says “adding” for about 30 seconds before the error message comes up.

Can anyone help?

Best regards

I may be way off base here, but seems like you need to another \ in front of DESKTOP. I recall something like that from when I went through this.

Hmm, this is how my Share looks -




Since this didn’t work, you might try entering your login details and then do a Restore.

Thanks Jim,

I’ve just tried that but it doesn’t work.

I’ve tried just logging in and seeing if I can see anything Under Setting>Storage, but again it isn’t showing the interenal SSD on the NUC (there is a 128gb one with ROCK installed and another 1TB SSD to store music directly on).

Logging into the Web UI I can see that the 1TB SSD is detected and properly formatted.

Thank you Slim,

I’ve checked all my sharing properties and permissions and they match the ones in your screenshots. I’ve also tried logging in now and restoring from there but get the same issue.

Appreciate your assistance.

I need to log off now unfortunately so may not respond for 12 or so hours.

1 Like

When you get your next chance, you might try accessing your backup storage with the IP address of your NUC rather than the host name.


Thanks Slim,

I have tried that.

Will see if @Suppport can help. #support

Hello @Nick_Wood, thanks for the report. I would like to know more about your network setup. Also, do you have any issues navigating to that file path over your network? If you try from another machine are you able to see your backups?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.