New router - Roon core only detected on some devices

Need to change my router (for non Roon reasons). However when I install new router Roon Core only seen on some devices. Roon Core on Windows 10 machine with direct Ethernet to router (via 1gb switch).

New router uses same addressing scheme and subnet as old router and no devices defined as static IP - all non static from DHCP.

Roon Core seen on one device running RAAT, but not on another device (direct ethernet, not wifi in both cases). WiFi devices (tried 2 - a laptop and a phone) no longer sees Roon Core.

IPCONFIG on Windows 10 devices all show correct subnet ( and gateway (

Reverted back to old router and all fine.

Any ideas as to how to troubleshoot this please?


Power cycle everything to make it pull an address from the new router (and advertise its MAC).

Windows 10 will assume it is a new network (which it is) when you change the router.

Pull up “Network & Internet” in Settings.

Select “Change connection properties”.

Make sure it is set to “Private”

Public will hide you from the network.

Hope this is it.
… MD

Hi Mike(s)

Thanks for both your suggestions.

Yes I did power cycle everything (twice) - I did it the easy way by turning off the mains. :grinning:

Yes all devices set to ‘Private’. Double checked that by being able to navigate to all devices via File Explorer as well as RDP.


Is the Roon core set to Static?


Hi Mike

Thanks for your further thoughts. So far as I know there is no way of setting a static IP in Roon Core.

Roon Core in my instance is on a xeon machine running Windows 10 pro with IP gained from the router’s DHCP and not set to static.

However - on the windows 10 machine I do run Hyper-V which does (internally) establish virtual network connections with static IPs (to serve the spawned VMs (virtual machines). I do wonder if somehow things are getting confused by Roon in not propagating (multicast?) its presence correctly across the LAN because of the Hyper-V settings? I’m loathe in mucking around with the Hyper-V settings due to the risk of losing the VMs.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.