New TIDAL login method --- failure message

Started having a problem with Tidal last night. I know others have had issues with this but first time for me. Have Build 521 everywhere. Had to change my Tidal psw, have been logged in so long I didn’t remember what it was. Logged in from my pc no problem. Logged in from Roon I get the success page but it still not does not work from remote. Power cycled everything. What am I missing?

Moved to @support.

A post was split to a new topic: Trouble logging in to TIDAL with new method

Hi @Mike_LC,

We’ve enabled diagnostics so we can take a closer look at what’s occurring here for you. Can you describe your Core machine and networking setup in the meantime?


NUC8I7BEH/Rock, Asus GT-AC5300 8 port router, Ethernet to PC, all endpoints. Ethernet was added yesterday Friday morning. Wireless prior to that.

Thanks, @Mike_LC — The diagnostics report came in and the team is looking into this. I’ll be sure to follow up with you once they’ve analyzed the report.

In the meantime, I was hoping you might be able to try logging in using Chrome as your browser — Is there any change when doing this?

Hey Dylan, I don’t have Chrome installed on my PC. I do have Firefox and IE. IE was the default. I changed the default to Firefox.

I had tried the Tidal login from my IPAD Pro 12.9 and it did not work either. Similar to the PC, login was successful but Roon did not recognize it.

Tried the Tidal login through Roon again on the PC with Firefox as the default and it was successful this time. After restarting the Remote the overview page is back to normal with Tidal and Qobuz selections and both are included in New Releases for You.

Thanks for the update, @Mike_LC! I’ve passed this information along to the team so they can continue to look into this, but for now I’m glad things are working for you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.