New to Roon and having a Chromecast issue

Roon Core Machine

ROCK running on NUC N2820 (unsupported) with 8GB RAM and 120GB SSD.

Networking Gear & Setup Details

Unifi network (USG3 firewall, UAP-AC-Lite AP and several US-8 switches)
All audio components on a single subnet via LAN or WAN. Switches have multi-cast and IGMP snooping enabled.

Connected Audio Devices

Lots of options, trying to work out what’s best.
Numerous Chromecast Audio’s and some Nest Mini’s
Denon X1200W (that supports HDMI/Toslink/Analog/Airplay)
Samsung S60A (that supports HDMI/Toslink/Airplay/Chromecast)
Cambridge Audio Dacmagic 100

Number of Tracks in Library

Description of Issue

The problem, is that my Chromecast Audio’s are not able to reliably send high quality audio to my DAC via Toslink. The signal/audio drops and pauses anytime the datarate is >48kHz. I don’t know if the problem is my DAC or the Chromecast Audio’s, but I’ve tried via wifi and via LAN and I’ve tried direct from Qobuz with the same result (Tidal works because it seems to downsample to 48kHz for the Chromecast).

I can successfully send to a Chromecast Audio connected via Toslink to my Soundbar (purely for testing purposes since it natively does Chromecast itself) so I think the problem is a compatibility issue between the Chromecast and the DAC at >48kHz. I don’t think this is a Roon problem, but I’m mentioning it here in the hope that the hive mind has some solutions. In the absence of this Chromecast Audio → DAC working I’m looking at other audio paths which leads me to the questions.

Chromecast audio supports up to 96/24 through optical. In my setup, that’s what Roon down-converts to, whether I play Qobuz or local library, and I haven’t had any issues. I would first make sure Wi-Fi quality is good enough before looking for other problems.

It is converting as required (no higher than 96kHz) but the audio chops and stutters. I’ve tried multiple chromecast audio’s and the common theme seems to be talking to that DAC. The DAC works fine doing USB at the same rates, it must just be a compatibility issue with the Chromecast Audio (which is a pity since that’s what I’d bought the DAC for).

I’ve tried wireless and LAN (I’m using usb-to-go converters for the Chromecast so they are normally using LAN rather than wifi) and both had similar result.

I suspect it’s just one of those things TM. The annoying thing is it disrupts my ability to stick with a single setup (Chromecast) and a separate Roon/Airplay issue means that I can’t use Airplay instead because a different room/amp breaks.

I would also make sure it’s not the optical cable. I’ve used Chromecast Audio with 3 different DACs so far (Schiit Modi, Klipsch R-15PM and SMSL SU-8) and didn’t have any issues, although I don’t know for sure if I used 96kHz with all of them since most of my music is 44.1.

Wow, I never thought of that and the cable in question is my crappiest and most used. My successful testing in another room was using a different optical cable. Thanks! Will test and let you know.

Chromecasts have always been a bit finicky with hires over their optical ports, google and you find this out. Some dacs dont get on with them at all. Also Roon is not like other apps that would send compressed flac direct to the device and let it decode. All decoding is done on the core machine to LPCM which is then sent on. This puts more of a strain on wifi networks especially if they are 2.4ghz s its much large packets of data. Cant say I have issues with my CC audio butt then its plugged direct into a little speaker via analogue out and not a dac. My other Chromecast wireless speakers only support 48/24 according to Roon and work flawlessly.

I haven’t had time to do a lot of testing, but I changed my optical cable and thus far it seems to be working ok. I’d put the cable in the basket of either works or doesn’t and never considered that this might be part of the problem.

I’ve done so much messing around with different hardware in the last few days that I’m now rebuilding my ROCK and starting from scratch with the new cable… fingers crossed and will confirm soon :slight_smile:

1 Like

While it could be the cable, I would be surprised if it was.
My experience says a toslink cable either works or it doesn’t.
Much more likely are the ends of the cable and/ or the ports they " lock" into either end.
I have one unit where the toslink out port does not lock down on the cable end when inserted any more. This did cause issues with playback similar to your description.

Unfortunately the only fix in my case was to use some tape judiciously to keep it snugged in. Fortunately this is out of sight and just works.

So it could be in your cable replacement you seated the ends more securely or the new cables ends are a better more secure lock into the ports.

With luck you are good to go and can enjoy your music.

1 Like

Some older Toslink cables could not perform above 24/48. I had a few older one’s that I finally tossed out and only kept the one’s that worked at 96
But generally agree that if they work they work.

I do wonder whether WiFi signal quality can impact this, especially if down behind a cabinet as I have also seen this myself.

1 Like

I was not aware some Toslink cables were limited to 24/48 max transmission rate.
However that does also sound like a valid reason that change of cable could have done the trick here.
Nice one.

1 Like

Well, I’ve rebuilt the ROCK and have now done a bunch more testing and my audio is now pretty reliable. I’m still getting occasionally millisecond skips that are only affecting the DAC/toslink Chromecast so it’s possible that there’s still something funny going on but overall it’s gone from non-functional to functioning pretty well. The skips are very short, but obviously very annoying so I’ll try another cable when I can (that doesn’t need an adapter to 3.5mm) but it seems like that was the root cause. Thanks for your assistance!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.