New user. “Roon ARC unable to access Roon Core” [Not Solved as of 18 March 2023]

New Roon user here…

Roon Core Machine

RoonServer (not sure of version, but it updated just last night) running on a Mac mini (2018) 3GHz 6-core i5, 32GB, under macOS 10.15.7. Various clients within the house are connecting to it just fine, playing music from my own library and streaming from Qobuz and internet radio.

The RoonServer Mac is connected to the home network by ethernet only, with a static LAN address of, listening on port 55000

Networking Gear & Setup Details

Router is an ASUS GT-AX11000, firmware operating in “wireless router” mode. NAT is enabled (I’ve tried both symmetrical and fullcone). UPnP is also enabled.

I have a fair number of IoT devices on the network (especially wifi, of course), and frequent guests visiting — so I’ve elected to set the subnet mask to Via DHCP, it assigns addresses from to, leaving 10.9.0.x addresses for manual assignment.

  1. Who is your internet service provider?

Elon Musk’s “StarLink.” Its modem is set to bridge mode. It’s upstream from the ASUS GT-AX11000, connected via direct ethernet. gives the following info:

IPv6: 2605:59c8:2100:83f2:5808:e6eb:a0e9:a88e


I have no idea about the IPv6 number, but the IPv4 address does change from time to time.

  1. Please list the make and model of your modem and router?

See above.

  1. Do you have any additional network hardware, like additional routers or managed switches?

I have had a Deeper Network Mini connected in-line (via ethernet) between the ASUS router and the StarLink modem, but I’ve routed around it while attempting to troubleshoot Roon ARC access. I get the same results with it in place and bypassed.

  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?

I do have it set to use custom DNS ( and from Cloudflare — but the router advertises itself then as the DNS server to its DHCP clients), and there was also the Deeper Network Mini (see above); otherwise, no.

Connected Audio Devices

Probably not relevant. But I have a Denon DRA-800H connected to the network by ethernet, as well as the latest model of Apple TV (also ethernet). Various HomePods (wifi) and SONOS Ones (one pair via wifi, one via ethernet).

Description of Issue -

The message reads:

"ipv6_connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: connect ECONNREFUSED 2605:59c8:2100:83f2:7d17:f0c9:23ff:eb9a:55000, response code: undefined, body: undefined"},
"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"","actual_external_ipv6":"2605:fff:ggg:hhh:iii:jjj:kkk:lll","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"","found_upnp":true,"error":"doaction request return statuscode: UnknownError"}

EDIT: I should add that this is a very new set-up, and that I have not at any point had Roon ARC working.

I have a little experience with this level of network troubleshooting, but I’m almost out of my depth. I’d appreciate any guidance anyone here can give me!

Starlink uses CG-NAT (a way to provide IPv4 addresses that are not actually real IPv4 addresses) and does not work with the current implementation of ARC:

There is now an update in earlyrelease testing that shall make work ARC with the new IPv6 and hence hopefully with all CG-NAT afflicted ISPs.

If you want to (but I don’t know how comfortable you feel about that as a new user; though it’s not actually challenging and as you have experience with a little network troubleshooting you will be just fine) you can join earlyrelease testing. It may be valuable for Roon to have testers with Starlink. Else, a bit of patience and hopefully this version will be released soon to all users. The instructions for joining earlyrelease testing are here:

The info about the IPv6 testing is here in the Early Access area of the forum:


Thank you so much, @Suedkiez ! I had been aware of the IPv6 / early access testing, but hadn’t seen that it was relevant to Starlink users.

Starlink has been a mixed blessing to us in this very rural spot. Fortunately, fiber should be available within the next few months…

I’ll be off-site for the next few hours, but will investigate the early access program and pursue this further after I return.

1 Like

OK, well … nope. StarLink still doesn’t work, even with the current early access version of RoonServer installed. My updated ARC test results follow, in case they’re of use to anyone:

"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"129.ddd.ddd.eee","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"","found_upnp":true,"error":"<s:Envelope xmlns:s=\"\" s:encodingStyle=\"\"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns=\"urn:schemas-upnp-org:control-1-0\"><errorCode>718</errorCode><errorDescription>ConflictInMappingEntry</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>"}

Please post this in the early access thread so that the developers see it. Maybe you’ll get suggestions/help as well.

Plus this looks like a UPnP error, and IPv6 doesn’t need or use UPnP (or port forwarding in general). Maybe it’s just a question of setup/configuration.

I re-categorized this to Early Access.


I’m confused.

If my problem with ARC is with UPnP, then why did you advise me to move to the early access version, and re-categorize my query there?

Or is my ARC problem with IPv6?

I’d just like to be able to use Roon ARC, and I have no idea how to interpret these error messages.

@Robert_F can you remove the “Solution” check mark from the thread? It’s not anymore

1 Like

Unfortunately it appears Discourse does not allow edits to the Solution tag after a period of time. I will edit the title to note that this is not solved presently.

1 Like

The regular production ARC version only works with IPv4 addressing, which requires port forwarding. One way to configure port forwarding is automatically by UPnP (or else by setting up port forwarding manually)

However, Starlink uses IPv6 at its core and relies on CG-NAT (Carrier-grade Network Address Translation) to provide an additional limited IPv4 address for your internet access. These are sufficient for web browsing and the like when connecting to servers that use IPv4 and have not implemented IPv6 yet. However, these CG-NAT limited IPv4 addresses do not support port forwarding, so the regular ARC cannot work with CG-NAT.

The new test version in earlyaccess is able to use IPv6 addressing and does not require IPv4 addresses and hence port forwarding, and therefore is not affected by the CG-NAT limitation.

However, IPv6 does not use port forwarding and hence UPnP at all, so it is weird if you still get an UPnP error message with the earlyaccess ARC. This might be just a configuration issue on the router. But also see my next post below.

There is some more info about what the earlyrelease version provides in this regard here:

Ensure that you did not only move the Roon Server to earlyaccess, but also your Roon apps on the control devices (Windows, Mac) as well as the the Roon remotes (iOS/Android) as well as the ARC app (iOS/Android).

In short, you must install earlyaccess versions instead of production version for everything. Follow the instructions in the early access help page that I linked:

If it’s too much trouble, stay on regular production releases and then your ARC access simply will have to wait until the new ARC with IPv6 stuff moves from the earlyaccess testing to the regular production releases

Thanks, @Suedkiez ! — yes, I did upgrade all my clients (macOS, iOS, and iPadOS) to the EA versions when I upgraded the RoonServer.

I’ve now been through “Roon Networking Best Practices,” too. Other than setting my ASUS router to “enable multicast routing,” though, there wasn’t really anything new there for me.

That one toggle seems to have changed the “natpmp_autoconfig” from undefined to, which seems like a step in the right direction. But I still get this error:

"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"129.ddd.eee.fff","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"server_ip":"","found_natpmp":true},
"upnp_autoconfig": {"server_ip":"","found_upnp":true,"error":"<s:Envelope xmlns:s=\"\" s:encodingStyle=\"\"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns=\"urn:schemas-upnp-org:control-1-0\"><errorCode>718</errorCode><errorDescription>ConflictInMappingEntry</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>"}

As I don’t have Starlink and the IPv6 stuff is all new (and I can’t use it with my ISP) my experience with setup is limited. Paging @Early_Access, can you help here please.

Hi @Erik_Mueller-Harder,

Thank you for your willingness to contribute to our #earlyaccess testing, and please accept our apologies if the switch to the Beta group has rendered your system inoperable for nearly two weeks.

The team is actively testing Starlink compatibility with IPv6 and I’ll merge your detailed notes there shortly. The details you’ve already provided are immensely helpful as we troubleshoot, so if you’re eager to get ARC functional in the meantime, I recommend the TailScale workaround here: Tailscale implementation with ARC to circumnavigate ISP CGNAT

The above thread concerns Synology users, but for a Mac user like you, there are also instructions here: Setting up Tailscale on macOS · Tailscale. It’s a simple app for your Core and Remote (phone) that circumvents port forwarding. Put simply, it will safely extend your local network to the phone outside the home.

In the meantime, we’re working with other Starlink users to work this out. I’ll report on progress in the main IPv6 testing thread as soon as I have an update: Testing IPv6 support in Roon (for users locked out of ARC due to ISP reliance on IPv6 or CGNAT)


Thank you so much for your response, @connor! I’m actually familiar with Tailscale, although I haven’t used it much. I’ll give it a shot!

I rarely leave home (and there’s basically no cell coverage nearby), so I may not be your most useful tester, but I’ll do what I can.

Last week, I was on a day trip and found that the early-access ARC was able to communicate to some extent with my server: I was able to see some of the composers and albums in my collection and get a list of recently-played tracks. There were some time-outs and it often didn’t show me everything that I expected (even when I had strong 5G and 5G UC T-Mobile signals), but it was clearly getting live data from my early-access Roon server.

Attempting to listen to anything always failed, though – just a spinner and eventual time-out.

1 Like