Newbie trying to get Roon to choose sample rate [Solved, Zone pick]

Hi, apologies for I know not what I do. I’m trying out Roon now, and investigating hi-res for first time.

  • Roon installed easily and instantly sounded great on most of my music (both ALAC 16bit lossless and AAC).
  • I bought my first hi-res album (Radiohead, A Moon Shaped Pool, ALAC 48kHz 24 bit 2ch according to Roon). I thought that Roon would automatically choose the right sample rate, but it isn’t doing so. Instead it tries to play it in the default 44.1/16.

Anyone know what I’m doing wrong?

  • My set up: Roon app downloaded on my Macbook Air (2014); music is stored on the MBA, playing through Dragonfly Red and Jitterbug.


Maybe post a couple of screenshots of your audio setup in roon. have you ticked exclusive mode? Roon should sort out the correct sample rate if its setup correctly.

Hi Steve,
Good point. It looks like Exclusive Mode might not be available. This is what I’m seeing:

this seems to be what I should see, according to Knowledge Base:

However, in the Knowledge Base article on Exclusive Mode, it says OS X should support it. Is there perhaps a setting in OSX that I should change? I have Sierra (10.12.2)

You appear to be outputting to System Output (the default sound card through the OS mixer).

Can you see the DragonFly directly in Settings > Audio? If so – enable it, name it and play! Exclusive mode cannot be applied to the OS mixer for obvious reasons, but will be available once you enable the DragonFly as a zone.

1 Like

Yep. Rene is correct.

Choose the dragonfly for playback and configure it instead of the system output.

1 Like

Ah ha! That’s great - thanks!
Now the question is: it looks like it’s set up for the Roon volume to be maximum, which means I can only control the volume on the amp, not on core or remotes. Is that how it should be, or can I change that?

In the device settings of the DragonFly, you can choose how volume control is handled by Roon.

If the DragonFly supports it, you can choose ‘Use Device Controls’ here so Roon can use your device’s volume control. If it doesn’t, you can pick DSP Volume. In the latter case, Roon will apply a 24-bit, dithered volume control. Technically, you will not have a bit-perfect output any longer, but Roon’s DSP volume is a high quality solution for your convenience.

1 Like

The User Guide can help reduce the learning curve, but the Forum is here to help as well.

1 Like

Thanks very much to you all. I just found I had so little context - I’m so new to the whole idea - that I was floundering a bit despite the excellent user guide. However now I’m starting to get a handle on the vocab, I should be able to play with it from here.


Once you’re setup the rest is just fun :slight_smile:

1 Like

It occurred to me that this issue has come up a few times now, so I wonder if perhaps System Output isn’t the best default output for Roon to choose? Or maybe it needs some extra blurb on the interface when you first install it?