Newly created Roon setup: Windows Roon and IOS Roon remote crashes at startup

Roon Core Machine

Roon Core on brand new NUC12WSW (running latest SW - no problems identified, ffmpeg installed)
Connect via ethernet. Status is fine

Networking Gear & Setup Details

UDM Pro (Unitfy)

Connected Audio Devices

Only Sonos so far

Number of Tracks in Library

Non so far (I did not even add streaming services yet)

Description of Issue

After I got the Roon Core up and running on my NUC and everthing looked great I installed the PC Roon app to start testing.
During the installation I ended up NOT choosing any streaming services as I only had Spotify. Also decided to wait with connection to my NAS
After installation of the PC Roon app (windows) I signed up for Tidal (now tested and Tidal is streaming)

When I start up Roon on Windows that app just closes after 2 seconds.
Same with Roon Remote on IOS.

Can I be because I never managed to setup streaming services (signed up to Tidal AFTER setup)?

I have tried reinstallation of windows Roon but same results ;(

I was looking SO much forward to play with Roon but now I’m stucked and can’t get anywhere.

Both the Windows Roon app and the IOS app found and connected to my NUC Roon Core server.

Please help
Jesper Manigoff

The problem is this:

The current Roon Server Software version should be Version 2.0 build 1234 production.

Current releases of control devices / remotes crash when the Core is not up do date. Some Cores / ROCKs seem to have got stuck at an older build, or are brand new like yours and then this happens (because the download ROCK image is not the latest). If all your remotes crash then you can’t initiate the update from the remote but you can trigger the update by going to the admin web page and clicking the Reinstall button for the Operating System:

(From the Updating Nucleus help page)

This will also trigger the update of the Roon Server version. This is riskless and has helped in countless recent cases.

Roon are looking into this to prevent the remote crash or hopefully will update the ROCK download image.

Thanks Suedkiez. YOU SAVED MY DAY!
Will do it right away :slight_smile:

Happy weekend

1 Like

Enjoy, hopefully soon :slight_smile:
It’s a bit annoying that this is currently the first experience and I hope they can fix this soon

Thanks Suedkiez
Tried the solution but although NUC states that it’s downloading and installing and restarting, it stays at version 1.0.
Tried mulitiple times and even power off / on.
Still the same. Seems like it’s just stucked at Version 1.0 Build 256)
Any other ways to force such an update?


The is the base Roon OS (operating system) version and Version 1.0 build 256 is the lastest. That’s fine. It changes very rarely.

The important bit is Roon Server Version, and clicking the Reinstall button for the Operating System should also trigger the update for the Roon Server Version like I wrote. After the update this should say Version 2.0 build 1234. (It did trigger this as expected in countless recent case with the same issue).

Really strange…
I upgrade BIOS on NUC. Then it all started working although Operating System still says “Version 1.0 (build 256) production” and I can’t get it to upgrade…

But it works… The Roon Server is the latest according to Roon homepage.
So I guess it’s all OK for now…

Like I said, that won’t upgrade further for now because it is the latest available version for the operating system. From the release notes forum page:

The issue was that your Roon Server version was outdated, it said build 1143 in your first screenshot. (Which is normal for a fresh ROCK install, hence the need to trigger the update). If it is now “the latest according to Roon homepage” then it should say build 1234 and then you are good. That was the critical part. (Updating the BIOS is recommended for a new NUC anyway in the ROCK install instructions, so good move)

Thanks - I misunderstood the message to begin with. Thought it was the Operating System that needed upgrade. Thanks for helping out. I’m enjoying Roon as we speak. Big time!

1 Like

Happy it helped. Have fun!