NFS path on QNAP to Linux

Managed to get Ubuntu loaded on my new NUC (total Linux noob, so took a while).

RoonServer is running and visible from my iPad. Set up an NFS share on the QNAP with read-write privileges for a Roon login. I’ve mounted the NFS share on the NUC to /mnt/Roon.

Problem now is what path do I set in RoonServer for the watched folder on my QNAP? Shared folder is called Roon.

Thank you.

/mnt/Roon :slight_smile:

I tried that as a local folder, but it didn’t show any files at all.

Maybe I need to check the mount again.

Thank you.

I wonder if you would be better served by setting up Roon pointing to the QNAP as an SMB share on a specific IP address…i.e. a Network Share rather than a Local Share

i.e. use your Router to allocate a specific IP address to your QNAP…and then Roon points to that address and folder


Well it doesn’t look like it’s mounting.

I’ve edited the /etc/fstag to include the following line:

“ /mnt/Roon nfs username=administrator,password=password 0 0”

But no joy. When I go “sudo mount -a” I get an error message showing no mount.

I can’t disagree with you Ronnie, it would just be nice to get NFS working, that’s all.

Syntax looks right. Is nfs-common installed on the NUC?

Before you put something in your fstab, first try it simply to mount it from command line:

sudo mount /mnt

I’m wondering a few things:

  • did you set the correct export on your NAS? So it the share really available under ‘/share/Roon’?

NFS-common is installed.

Thank you, spockfish.

I get “Failed to add /run/systemd/ask-password to directory watch: No space left on device
Mount.nfs: access denied by server while mounting”


It tries to come up dialog so you can enter the password, but the ‘no space left on devce’ message is rather intriging.

Could you please check if you have room left on your NAS? And the same for your NUC?

On the command line this could be done with:

df -h

Highest usage is 81% on NAS (/mnt/RoonStorage). The rest lie between 0% and 28%.

SMB share is working as seen above.

Thank you.

and on your NUC?

That includes the NUC. NAS 81%, NUC no higher than 28%.

weird. i can’t understand why systemd claims that the device is out of space.
The issue itself is known, but with a very old kernel and systemd version.

So let’s forget that one for now at least. I assume it’s a permission problem.
Could you run the same command but now like this:

sudo mount -t nfs -o username=administrator,password=password /mnt

“Incorrect mount option was specified.” I used both a . then a , between the username and password options.

Thank you.

it should be a ‘,’

I presumed so, and tried both. Same result.

Thank you.

duh. Sorry!

It should be a capital letter O.


sudo mount -t nfs -O username=administrator,password=password /mnt

“Access denied by server while mounting” etc

Very sure username and password are correct.

I rebooted the NAS post changes to get everything running. I have an iMac to test it on that may give me more info. Time for bed, said Zebedee. Will pick up in the morning.

Thank you all for your suggestions and help.