No Airplay via Nucleus anymore

Roon Core Machine

Nucleus Version 1.0 (build 254) production, internal storage (Samsung SSD 860 4TB)

Networking Gear & Setup Details

FritzBox 7590 Ethernet via NETGEAR GS108GE 8 Port Gigabit Ethernet LAN Switch

Connected Audio Devices

Denon Heos 250, Denon Heos 350, Denon AVC-X6700H (WiFi Airplay and HDMI)
Mytek Brooklyn Bridge (via Ethernet an USB and HDMI, Ethernet), Denon AVC-X6700H (via Ethernet and HDMI)

Number of Tracks in Library


Description of Issue

Airplay from Nucleus to Receiver and Denon speakers doesn’t work anymore. I’ve never had issues with this, before (it doesn’t work neither with grouping or without). Other devices (MacBook, iPhone, Ipad are able to connect via airplay to all of the devices). Airplay speakers are activated in the roon settings and recognised. It gives me the option to play via airplay but stops immediately. Nothing changed so far. I have a feeling that since the last Roon Update there is this issue.
Already rebooted everything and updated: speakers, Receiver, Roon, Mobiles…Restarted Router, too. Problem persists. Already restarted Roon_Server file (changing it to *_old and connected “new Nucleus core”). Everything stays the same: I can activate Airplay devices (and others), they will show up but Replay stops immediately. Can anyone help here? I did not change anything (no new firewall etc.).

Thanks in Advance. Daniel

I would like to confirm that - my Nucleus has problems streaming via AirPlay to my Sonos devices as well. Playing stops between tracks. I switched to Sonos streaming now and that works.
Never had any AirPlay issues before.

The problem persists but I can provide some more Information: The moment where airplay did’nt work anymore, ARC shows “bad connection”. But it used to work properly, before. Even when I’m in my home WiFi there is a “bad connection”. So, the nucleus seems to be cut from some network protocol. Once again: I did not change anything apart frpm the roon updates and HEOS updates.
Moreover, I can add my MacBook in Nucleus as a speaker. The airplay connection here only works if I fix a certain passcode. The normal airplay passcode procedure won’t detect the macbook speaker. Once managed, I can “play” files from my Nucleus to the MacBook, but there is no audio ouput. Volume is normal. Music from the macbook itself does work. So, it is apparently a connection issue between Nucleus and remote speakers. One more time: airplay works towards Macbook (or Denon home Speakers) from any other device.
So, can anyone please help me? It seems a Nucleus (Software) Issue…?

Ok. Solved this one: I could not imagine but it was AppleHomeKit that changed the defaults in the background by updating itself silently. I had to allow acces to devices to everybody again and now it works. Sorry, but that did not happen before.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.