No Album or Artist Images for Any NEW Imports

Hello, I am hoping there will be a reasonably easy or known method of fixing this issue. I discovered an old post from late 2018:

My issue is nearly identical to the one experienced by @Michael_Steinberg in that post, all the way down to what I’m seeing in his screenshots.

Today I attempted to import about a dozen new albums. These are my first imports since early March. Nothing about my Roon installation or my remote apps (Win10 PC, MacOS Laptop, AND iPhone) has changed. For all of the new albums, they are identified correctly by Roon, but I get no artwork. Artists who previously already were in my database DO have artwork, but anyone or anything net new to my library are without images.

Note that it does not matter whether I select “Prefer Best” or “Prefer Roon” or “Prefer File” as they all say “No image” in the Edit dialog.

In addition, if I attempt to manually select the cover art from a folder on my network drive, I am unable to save the changes. I can see the image in the edit dialog:

However, when I click “Save,” the spinning icon comes up briefly and then goes back away without saving the change. After closing the dialog and refreshing the album page, still the same stock black-and-white image:

I have attempted to close and restart the Roon end-user app, but that does not help. And the issue exists for these new albums on all three devices where I have the Roon app installed (Windows, MacOS, iOS). Have also attempted to completely power cycle the device where the Roon Core is installed. No help.

Tried to completely remove a couple of these albums (including deleting the files from the monitored folder), and then re-imported. Same results.

Neither Re-Scan nor Re-Identify has changed anything.

The only thing I can think of that I have not tried yet is clearing the image cache. I’m somewhat scared to do that, because I do have over 1800 albums and 650 artists already in my library that are propertly displaying over 7400 images. I’d hate to lose all of those, too, if there is a bigger Roon issue.

As I said earlier, I have not made any changes to my system or any software updates to the core or clients. The 2018 topic I referenced at the start of this message never seemed to show a final resolution. I’m hoping maybe somebody can help?


I figure it was worth adding something additional. Here is a screenshot from the client app on my iPhone:

At the bottom notice, under Album Info, it does recognize that there is an image file available. For other albums with multiple JPEGs available, the correct number is displayed.

(I have actual cover art, and sometimes other images, stored in the folders alongside the music files. There is also cover art saved in the FLAC metadata for the majority of my tracks.)

If I click that images icon:

So Roon clearly is able to see the images files and read them from the network drive. The software
“knows” they are there. It just cannot store them to the actual album (or artist) info database.

Not sure if this extra info is helpful. But it seemed relevant to me. ¯_(ツ)_/¯

Hi @Jeff_Strauss

Can you try to unidentify the album? You can do this by choosing Identify and choosing the None of these look right options, and eventually, it’ll ask you to use file info only. When doing so does that work, or are you still seeing this issue occur?

Hi @dylan. Thanks for the response.

So things have been strange. I did try to “unidentify” and still was not able to obtain any new images for albums or newly added artists. But I did get things working, temporarily, yesterday.

When I kept digging, I noticed that my scheduled automated database backups have been failing for some time. After rebooting a couple times yesterday morning, I tried to force a manual DB backup to see what would happen. Roon acted liked it was going to work, and then the Core went offline for 15-20 minutes. When it came back online, the backup had not worked, but the image-free albums had disappeared from library. When I rescanned my network storage, they all imported properly.

Then, late last night, I was adding more albums. Things were fine until right around midnight (my scheduled backups are at 3am, for what it’s worth, not midnight) when suddenly I started getting the no-image problem again. I went to bed and decided I’d investigate this morning and write you back. So…

When I opened up Roon this morning, the handful of Otis albums I tried to add were still showing (without proper images) in my library:

I attempted this morning to move those albums out to an non-watched folder, rescan, and clean my library to remove them. At that point, they were gone:

However, as soon as I tried to add them back, I still had no images. Same result as last night, like the first image above.

So then I power-cycled the device with the Roon Core. Backups are supposed to be writing to a locally attached USB thumb drive. Figured maybe that device has corrupted. So I booted back up this time with that local drive completely removed.

As soon as Roon started back up, like yesterday, the misbehaving albums were gone from my library, but it immediately scanned/imported them again, without me doing anything. And they all loaded perfectly fine. Images for the albums:

And a proper new image added for Otis Redding:

I might try to write my Roon backups to my network drive to see how that goes, and possibly also schedule an automated nightly to that drive, too, to continue monitoring. Is it possible that my Roon metadata DB itself is corrupt? If so, would that explain the intermittent behavior where it works most of the time and then has sudden problems?

Sorry these updates are so long. Just trying to provide the most anecdotal information that I can.


Another brief update, @dylan. Turns out it was nothing special about midnight. I have attempted to import an additional four albums this evening, around 9:15pm local time (CST US), and again have the no-images problem where the album artwork (and, seemingly, the albums themselves) are not truly being added to the database.

The local thumb drive for DB backups is still not connected to the core, so that’s not the problem.

I’m really hoping that I don’t have to start with a fresh Roon core install from scratch, or a new database.

Hi @Jeff_Strauss

Thanks for the updates here, and sorry for the delay. Can you give us some information about the Core machine you’re using?