No artwork of any sort (album, artist etc.) showing after V 2.0 build 1128 installed

Roon Core Machine

Windows 11 on a HP-Envy with an i7

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library


Description of Issue

As the title says, after installing the update I have lost all artwork. I tried clearing the cache but no difference.

Have you tried rebooting your Roon Core?

Yes, multiple times.

You could try a database restore from a recent backup. Backups are not specific to a Roon version.

I have reinstalled the library from a backup, no change. I have reinstalled an earlier version of Roon and rescanned my library, everything is back to normal. Roon asks me to update to the latest version, I do and everything breaks.

Needless to say, at this point I’m not very happy. I’ve now been down for two weeks and have spent many hours trying to get to the bottom of this with no resolution in sight. When it works, I love Roon, it is a superior music player and database manager to Plexamp. Right now, I’m thankful I have Plexamp.

Hi @Chris_Jenkinson,

I’m sorry you’re having issues. Artwork is an important part of the Roon experience!

One thing I noticed in looking at your account is that somehow, the updates failed and you’re still on an older version as a result.

If you want to go to Roon 2.0, use this link on your core and update your android or iOS devices by looking for Roon Remote 2.0 in the Play or App store.

If you want to stay with 1.8 (no need unless you’re not capable of running and from what I can see you are) please click the link here. You will need to search for Roon Remote Legacy on mobile devices to use Remote.

Please let me know if you have any questions or issues after the updates!


Thanks for the follow up, Wes. The artwork is certainly an irritation but more importantly, it is also causing issues with some of my players showing up.

I have just installed Roon 2.0 from the link you provided and the results are the same; Roon can not access my library and No music player are showing up. I also updated my iphone app to 2.0 and it can not find my core.

The only thing I can see that could be causing an issue is my “C” drive is very low on space. Is there anyway to force Roon to install on a different drive?

Hi Chris,

Wondered if you were using a VPN with split tunnelling at all? All my artwork disappeared on the core for this reason (although I did not have the players issues).


Hi Jason,

I was using split tunnelling with Express VPN but, I disabled Express VPN thinking that might have something to do with it. However, it made no difference. Now I cant get anything to load with either the latest or legacy versions.

Sadly, that was my only idea due to my experience with cover art. Good luck, it might be one for the Roon experts now!


How low is low?


1 Like

143 GB free. Is there anyway to make Roon install to a different drive?

Hi Chris,

That should be more than enough space. Quite ample indeed.

How are things going for you right now? I wanted to take a deeper look into things so I enabled diagnostics. Your core is reporting just fine and it’s also reporting normal device behavior.

One of the things I noticed on logging is that your logs were filling up audio analysis messages. These messages appear to be constant. I think this means it’s having communication issues but I want to take a look at this with my development group.

Let me know what your current status is if you would please.


1 Like

Hi Wes,

Thanks for getting back to me and apologies for just now responding, I had to go out of town for work and am just now back.

Finally, I got everything back to normal. The fix was to delete everything and reload my library from scratch. I was having some network issues as well and I think I got those sorted at about the same time. Everything including ARC is back to working flawlessly.

Thank you for your efforts in helping to resolve it.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.