All Art disappeared from Roon Core

Roon Core Machine

Custom HTPC
Core i7 3770 @3.4GHz
24GB RAM (although 8GB is used as a RAM drive)
Windows 11

Networking Gear & Setup Details

Wired Network
Archer VR600v modem/router
A TP-Link TL-SG1016D Gigabit switch is the only thing in between.
Express VPN

Connected Audio Devices

Probably not relevant for this issue.

Number of Tracks in Library

61,894 tracks.

Description of Issue

Ever since I upgraded to Roon 2.0 all the cover and artist art does not appear on my core. This is also the case if I push to any of my (Android TV) displays. In place of the album art there is just a grey square (note that albums that did not have art still show the “grey CD on white background” image) and artists just have a circle with their initials.

Note that all art appears correctly on both Windows and Android controllers.

I have looked at several topics on this with no real answer apart from “it just seems to right itself after a while”, however it has been a while, with another upgrade since, and is still not working.

I have cleared the cache on the core to no avail.

I also noticed that one album had incorrect cover art on it, being a Various Artists collection that showed the cover art as a picture of Bono, so I tried deleting this album as well, but still no dice.

The artwork has always worked with no issues on this same system before the upgrade to 2.0.

I have my 50th birthday coming up in a few weeks and really want to show off the art and karaoke abilities of my system, so this is incredibly frustrating!


Hi @Jason_Schubert,

I’m sorry you’re having issues. I looked at some diagnostics for your account and I’m seeing a whole host of errors along the line of “Error loading image, network error”.

Have you restarted your core? I think that might be the difference maker after clearing the image cache as you did.

The next step is a fresh install which is slightly more laborious. I’ll list those steps below too.


  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Hi Wes,

Thanks very much for the reply. Since a few people had looked at the post and not replied, and I was concerned that there may not be an obvious answer, I did some of my own investigation.

As such I looked into the two other changes I had made to my system to get ARC to work, or more specifically, the one that was not at a service provider level, this being enabling of split tunnelling on my VPN. As such, I disabled this option, restarted Roon and my artwork has returned. ARC still seems to be working as well, although I am not sure if this is going to continue in the long run.

As such, I have a couple of follow up questions:

  1. Have any changes been made in the latest version of Roon 2.0 (I am running build 1133) to allow it to work correctly through a VPN or am I just lucky? Or perhaps once it has connected the first time, it has an easier job finding it again?

  2. If the above is not the case and I am going to continue having problems with the VPN, which application(s) do I need to not run through the VPN? I only had Roon\Application\Roon.exe split off, but have noticed several other applications that may need to be split off, with the first guesses being RoonServer\Application\Roonappliance.exe and RoonServer\Application\RoonServer.exe.

It is worth noting that ExpressVPN has a strange split tunnelling screen that only lists pretty much the browsers, with the “Add” button taking you to Program Files (which is not where Roon is) so even setting this up initially took me longer than expected. I am assuming this is going to be an issue if I change to a local logon in the future as well.

I am hoping this might help anyone who is having a similar problem and wondering if there is a way to tag this topic with VPN or ExpressVPN. It looks like I am unable to amend the original post now.


Hi Jason,

I wish I knew more about such custom setups. I know that when it comes to a VPN it falls under the category of tinkering since it introduces complexity that’s otherwise absent. I’m glad you made some progress though. Here’s one or two of the threads I’ve seen on the topic.

Best wishes,

Hmm, both these topics seem about using a VPN server in your home to access Roon from elsewhere. With Roon ARC this seems unnecessary.

I am just using a commercial VPN to hide my data usage from the prying eyes of my data-hungry government. I find it hard to believe I am the only one in this position.

Previously I have had to split-tunnel (i.e. not use the VPN) on Android controllers only, Windows ones worked fine with the VPN running on both controller and server. Using ARC was the first time I had to split-tunnel the server to get connected, however as I have now turned this feature off and everything is still working, I guess I just have to wait and see if it remains that way.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.