No audio devices found [Resloved]

I recently built a new computer and more often than not, Roon displays “no audio devices found” when I try to select which one of my DAC’s I want to use. Neither DAC nor my USB headset can be selected by Roon, even though I can use them as playback devices in Windows and use them with Spotify, games, VLC, etc. Roon runs on my Windows 10 machine, not on the NAS – the NAS only serves up my music files.

Occasionally, when I click the “Manage Audio Devices” button, my DACs, headset, and system output will temporarily appear for a few seconds and then disappear. Screenshot of this behavior is attached. Most of the time they just aren’t present in the audio device menu within Roon.

I’ve gone through other threads, this thread seems to be closest to my issue (user is using a DAC from the same company, same OS, etc) on this topic and tried various things, such as turning devices off and then back on, rebooting, etc. Nothing has worked.

Dropbox link for logs and larger screenshot image:

Roon + Audio Stuff:
Roon 1.3 build 218
DAC1: Maverick Audio TubeMagic D1
Headset: Razer Kraken 7.1

Motherboard: Asus ROG Maximus IX Hero
Processor: Intel i7-7700K Kaby Lake 4.2 Ghz (overclocked to 4.9 Ghz)
RAM: G-Skill TridentZ RGB DDR4 3866 Mhz
SSD1: Samsung 960 Evo M.2 256 GB
SSD2: Mushkin Chronos 256 GB
NAS: Drobo 5N

I uninstalled Asus Sonic Radar and some other Asus audio application that came with my motherboard, rebooted, and that seems to have resolved the issue entirely.

Nice work, glad you figured it out. You might also want to try the Event Driven mode under Playback if you use a WASAPI driver. That helped me.