“No audio devices found” when Core iMac is asleep

I also confirm that there are no audiodevices, even after changing the name of RAATServer.

The thing that amazes me the most is that roon core must be awake because I’m able to see all the songs of my library, surf through Tidal albums and songs and change settings. The only thing that isn’t working is the availability of audio devices.

As soon as I ga to the inlogscreen of my macbook air via screen sharing, the audio devices appear in the roon clients.

Other proof that the macbook with my roon core is awake is because I’m able to create new maps and files via the network.

@Patrick_Beaman

The steps I provided might help you. Please try and let me know.

Wes

@Wes

apologies for not being clear. I followed your steps. Renamed the RAATServer file and restarted mij laptop. Problem still exists.

New error occurring, all of a sudden ARC can’t connect for some reason.

Here’s the error message on my iPhone:

But when I open Roon on the Core, everything seems fine:

I updated my iPhone to iOS 16.0.2 yesterday, don’t know if that has anything to do with it.

Disconnecting and reconnecting seems to have fixed ARC, but the original problem remains.

Hi @Hestepare,

Let me check back with you here soon. I believe we may have other instances of this happening so I am having this investigated further.

Thanks,
Wes

1 Like

Thank you!

Hi @Hestepare,

As I understand it, others have seen this go away with an update and/or a core reboot. I see you’re on Roon 2.0 and our diagnostics show you’re on an appropriate version of MacOS as well. Can you try restarting your Mac? Also, please check the settings here under system preferences>Energy saver.
Screen Shot 2022-10-04 at 7.23.22 AM

Thanks for getting back to me so quickly. I have rebooted without any discernable change, but setting the power settings like in your picture + asking the iMac to wake in the morning and go to sleep at night is an adequate workaround. My issue is, however, that all of this worked well without asking the iMac to stay awake with those power settings, until 2.0.

Additionally, the iMac does wake on lan even without forcing it awake, the only thing that drops is the “audio” section. Browsing and handling the library works even when the iMac sleeps, but not controlling the audio section.

As a workaround I’ve set the iMac to stay awake during the day (in the power settings), but it still loses the “audio” section. This used to work but now it doesn’t any more, now I have to access the iMac to be able to use Roon.

@Wes, I’m just curious wether this is being worked on and if you need something more from me to figure it out.

Hi @Hestepare,

Can you verify that the option to prevent hard disks from going to sleep is selected in addition to the prevent going to sleep when screen sleeps?

Thanks,
Wes

I don’t seem to have that option.

1 Like

Hi @Hestepare,

Man are they odd with how they offer settings :slightly_smiling_face:. We are both on the same version too.

I have never advised third-party software to be used but this seems appropriate.

Try installing this and let me know what happens. We have a couple of other users that have had this issue and this was the resolution.

Same issue here: iMac 3.3Ghz Quad core / 24 GB 1867 MHz DDR3 running Montery 12.6.

Roon v2.0 1133

HI @Jason_Monfort,

Please try the same advice I gave @Hestepare and feel free to report back. Please do try tweaking your Mac power saver settings before moving on to amphetamine though.

Thanks,
Wes

For now it seems like the last MacOS update has fixed it. I’ll make sure to let you know if it falls out of order again.

1 Like

Unfortunately, no…

Overnight, it’s back to core being awake and accessible, but unable to communicate with the streamer.

That said, it seems to keep the connection for longer once reawakened.

For now it seems intermittent. I’ll keep quiet for a while and see if it settles.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.