“No audio devices found” when Core iMac is asleep

Roon Core Machine

iMac m1 24", latest software.

Networking Gear & Setup Details

Sagemcom modem (bridge mode), Linksys Velop router

Connected Audio Devices

Bluesound node 2i

Number of Tracks in Library

9287 - Qobuz only

Description of Issue

I have to wake the core machine to make the Node appear. Once that’s done it works fine until the iMac goes to sleep again. “Wake on network” is on and it used to work fine until 2.0. As you can see, browsing the library is possible and so is searching and adding or removing albums.

The only network change I’ve made was to set the modem/router into bridge mode as installing ARC revealed that there was double NAT going on.

I’ve restarted everything several times and deleted and reinstalled all relevant apps.

Accessing the Node with the bluesound app is possible and I can play music through that. However, waking up the node does nothing to help Roon, only waking the iMac will.

If the iMac is awake when starting the music, I can continue controlling it like usual, but if I pause it immediately loses contact with the node.

ARC works fine, however.

I have the same problem. No audio devices visible although I’m in contact with the Core via my iphone.

I first have to make contact with the core (roon server on old macbook air put away in closet) via screen sharing. When the screen of the core laptop is visible the audio devices appear immediately.

I can only imagine it’s a bug introduced in 2.0 - let’s hope there’s an easy fix.

Untill then I’ll have to cancel the auto sleep function of my macbook.

Just bumping as <1 day old topics are answered but not this.

I just factory reset my Node, but that didn’t help.

I’m case it isn’t clear there is no way I can leave the core running full power 24/7. This is not simply an inconvenience to me, effectively Roon is broken for me until this is fixed.

Using this support forum feels like shouting into the void hoping someone hears me.

Would it help if I installed Roon Server instead?

@support I know you guys are busy at present but has this report been overlooked?

Apologies in advance if you’re already dealing :pray:t3:

1 Like

I’m not support either, but…

You should be able to try it out indestructibly, after pulling a database backup, by installing Roon server in parallel and authorizing it as the core on start-up - you’ll have to restore a database backup to it then.

1 Like

@Hestepare

Don’t bother installing Roon Server as an experiment. I’m running Roon Server on a macbook air 2011. Everything works fine EXCEPT waking up after sleep: no audio devices available.

2 Likes

Could be related to this tho?

1 Like

@Hestepare Thank you for this suggestion. It’s a great one. The other possibility is that there is database corruption.

Try this first:
Navigate to your Roon’s Database Location. Find the folder that says “RAATServer” Rename the “RAATServer” folder to “RAATServer_old” Reboot the device from the Web UI

From there, it may be necessary to copy your database out of it’s folder to start Roon with a new one. If this resolves the issue, corruption is likely.

Wes

Hi Wes and thanks for responding. A few questions:

Where exactly do I find the database and the RAATServer folder?

Which device should I reboot and from which Web UI?


This one within the Roon app package?

I found these instructions:

But I don’t have a folder named RAATServer in my Library, or one named Roon for that matter.

This is the one (screenshot you provided).

The WebUI is only relevant for those using a ROCK or RoonOS core. My apologies for the confusion. In your case, once you’ve renamed the RAAT folder, restarting the Mac is what needs to be done.

Wes

A screenshot from my laptop (Remote)

No luck, unfortunately.

The RAATServer file didn’t recreate itself, it seems.

Hi @Hestepare

If you go to settings>audio are the devices there and able to be enabled?

Wes

No, there’s simply nothing there: